GNOME 42 - NAS and Pamac issues

After an upgrade to GNOME 42 I am experiencing a couple of issues:

  • NAS drive connected to my router is no longer accessible
  • Pamac no longer opens

Anyone experienced the same issues? Any solutions?

Run it from the terminal and see if the error message tells you anything. Pamac is unsupported on non-Manjaro systems, and it is not uncommon for it to break.

6 Likes

This isn’t going to solve your Pamac issue, but have you ever taken Bauh for a spin?
I use it for searching packages and occasionally updating, but from my experience, it keeps working each update or DE/kernel release.

Disable firewalld and see if the NAS works. If it does you will have to figure out which port to open to let the NAS through.

systemctl status firewalld (to see what state firewalld is in)

Pudge

2 Likes

I second bauh. I don’t use it very often but it works well when I do and nothing breaks. It even has good flatpak and snap support.

1 Like

Bauh works great. Thank you!

1 Like

I never enabled the firewall.

what exactly do you want to say by that?

Because Gnome was updated to 42 already 27 days ago ?

firewalld is enabled per default for installs with Apollo ISO.

When I try to access my NAS I get the following error message:

" Unable to access location - Failed to mount Windows share: Invalid argument"

Found that this is a known issue: https://gitlab.gnome.org/GNOME/gvfs/-/issues/611

2 Likes

The latest update resolved the NAS issue. All good for now…

1 Like

Just a heads up, when I tested the pamac-all package from the AUR last week it was broken. I confirmed this by running the below command and getting an exception:

 pamac checkupdates -a

As @Kresimir mentioned it is undependable between builds. You could check its status here:

https://aur.archlinux.org/packages/pamac-all

What I ended up doing was change to pamac-aur

 yay -S pamac-aur libpamac-aur

Personally I use pamac to search for packages from the Arch and AUR repositories. But prefer doing my install\updates from command line.

2 Likes