Gnome 40 overview flickering

Hello,

Im using Endeavouros for 2 months now, really enjoying it and never had an issue that I couldn’t solve untill now. After the Gnome 40 update, it worked normally for several days and then suddenly the overview started to flicker and lag like this:

Gnome 40 flickering

I am using dual Intel / Nvidia video. Things I tried so far:

  1. Both on Wayland and Xorg
  2. Most of the options that I found suitable from the Intel GPU Arch wiki
  3. Glxgears works normally, videos / youtube and so on - everything plays normally.
  4. Tried disabling all the extensions.

Any hints on what to look for or what to try would be much apppreciated.

At work on a Win10 machine, but completely remove the Intel driver and let it default to the mode setting driver.

Something like:

sudo pacman -R  xf86-video-intel

The reboot.

Thanks for the suggestion :slight_smile: Removing or reinstalling xf86-video-intel did not help, but what helped was that I reinstalled gnome-shell and it worked!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.