Git Clone working sporadically on my system

Hello everyone, this is my first post on here.

I have previously used Endeavour os with dwm and had little to no problems with it. I was using someone elses bootstrap script to set up the basic features of the system and I decided recently that I would do it myself from scratch.

I am however experiencing problems with a script has to call git clone. It seems like it just gets stuck and doesn’t actually clone or do anything. The program in particular is the doom emacs install script. I have tried many things but cannot figure out what is going on. I have internet access, I can go on, I can clone repos by myself ( occasionally this fails and I have to re-initiate). I have tried other scripts as well and the problem still persists, leading me to believe it is my system.

Any ideas on what to do? let me know and I will provide any additional details. I am on a clean endeavour os build without a desktop, with dwm installed and alacritty as my terminal.

No problems here. Also an emacs user. To install Doom the method on the github site is:

git clone --depth 1 ~/.emacs.d
~/.emacs.d/bin/doom install

The git clone will fail if the directory exists, did you move ~/.emacs.d out of the way?

1 Like

First of all welcome to the community.

I have moved the topic to applications since it is a related bug on either git clone or the specific script and not a bug on the ISO or the EndeavourOS apps. :wink:


Yes i have taken this into account an moved .emacs.d out of the way before cloning. In fact the initial clone works normally most of the times. I just installed ubuntu out of curiosity to see if it would work and it still didn’t. It seems to be a problem when a script calls git clone or tries to clone something from a repo. Its think it might have to do with the speed, it might be downloading so slow that it fails. However if i go on or download a file directly from a browser my speed is upwards of 500 mbps so it should not have any problems regarding speed. I have tried updating the arch mirrorlist as well and this did not help anything.

Thanks for the welcome, and for moving the post to the correct category.

Can you share the exact script or git clone statement you are using?

Also, can you share the exact error you are getting when it fails?

Here it is , it is the same one xircon sent

git clone --depth 1 ~/.emacs.d
~/.emacs.d/bin/doom install

I’ve gotten different types of errors both could not connect to github at port 443 and this one

 Message: File is missing
  Data: (file-missing . "Cannot open load file")
    (require straight "/home/user/.emacs.d/.local/straight/repos/straight.el/
    (let ((repo-dir (doom-path straight-base-dir "straight/repos/straight.el")
    (doom--ensure-straight (:host github :repo "raxod502/straight.el" :branch 
    (let* ((--cl-rest-- (alist-get (quote straight) packages)) (recipe (car (c
    (let ((packages (doom-package-list nil (quote core)))) (let* ((--cl-rest--
    (progn (if doom-debug-p (progn (let ((inhibit-message (active-minibuffer-w
    (if (or force-p (null (and (boundp (quote straight-recipe-repositories)) s
    (eval-buffer #<buffer  *load*-854240> nil "/home/user/.emacs.d/core/core-
    (load-with-code-conversion "/home/user/.emacs.d/core/core-cli.el" "/home/

I have a strong suspicion this has to do with my network, I just don’t know where to start.

Ok I deleted .emac.d again and the initial clone has stopped working . I am stuck at Cloning into “/home/user/.emacs.d” ill wait to see if there is an error message.

Here is the error I got.
fatal: unable to access ‘’: Failed to connect to port 443: Connection timed out

Yeah, looks like a network issue of some sort. Is there an https proxy between you and the internet?

No there shouldn’t be one. Haven’t set one up or anything. I’m on my home network.

Troubleshooting that is more of a network troubleshooting process than a system troubleshooting process. Could be your router/firewall config or something your ISP is doing.

As a workaround, you could always just download the zip and unpack it to the proper directory.

What @dalto said, try restarting your router.

I’ve tried that but I’m going to try to factory reset it now lol.

The errors are Elisp, I will try and replicate using chemacs as I have a working Doom installation, but prefer my own config :smiley:

:edit: nope working here.

I have confirmed that this is a network wide problem. On my laptop i am having the exact same issue. I have reset my my modem/router to no avail.

Update. I connected with my vpn and the install is working perfectly


If anyone has any ideas about why this would happen let me know. I might have to contact my isp or switch network providers lol.

When you make a vpn connection you are bypassing many of your own and your ISPs rules.

It could still be something wrong with your network or something nasty your ISP is doing.