Getting the M.2 Port to work on a cheapo laptop

Using a Mercer guru which appears to have an old American Megatrends BIOS in which I can locate zero options for the m.2 slot this laptop comes with.
Tried using both a Sata M.2 as well as an NVME one to no avail

GParted on EOS does not appear to pick the drive up natively
However the drive does appear to be receiving power as it gets slightly warm when connected

Any clues?

Are you able to tell me what the make and model of this laptop? Also maybe post the hardware output.
Post the url

inxi -Faz | eos-sendlog

Edit can’t find much info on this laptop.

I cant either, all I know is that its called a Mercer Guru with an Intel Celeron J3160

Is it this thing?
EDIT: I’ve never heard of these Mecer guys but it seems like this thing has been discontinued. Why is this so hard to find? It’s like it’s been scrubbed from the internet haha

1 Like

That does appear to be it

Running Aptio Setup Utility American Megatrends 5.11 Bios

In the Bios look for SATA and try to set AHCI.

Edit: Make sure it’s not set to Raid.

1 Like

SATA Mode Selection is set to ACHI with no other options actually present

I don’t actually see RAID settings anywhere here

Did you install an m.2 drive yourself?

Yes, tried both a SATA M.2 and an NVME M.2, niether work

I only use nvme drives. Are you sure there are no settings to enable it in the Bios? You need to look under every submenu in settings. Check in advanced.

Edit: Unfortunately i can’t find a manual that would show the Bios settings screens.

1 Like


Maybe you could also post the following after. Post the links.

sudo dmesg | eos-sendlog
journalctl -b -0 | eos-sendlog

Here is a quick video demonstrating the options I have in my BIOS

Unfortunately it plays way too fast to actually see it. If you could post an actual video file that i could open within a player i coud start and stop it at least.

Nothing jumps out at me in the logs but I’m not an expert either.

Have you tried SATA test mode enabled?

1 Like

Do you have a second machine where you can check that it’s not the drive that is the issue? It could also just be that the slot is damaged/defective. I would check that after what Rick suggested if you are able to.

Yeah the drive works fine, and the slot also appears to be doing something as the SSD does get warm connected

Changing the BIOS to test mode does not appear to do anything although I am just checking in GPARTED

You should have turned off CSM support also. Are you installed in UEFI or MBR mode?