Geogebra 3D plantage

Bonjours et meilleurs voeux,

Petit problème de janvier, geogebra 5 plante (version installée avec pacman ou portable):
Pour la version portable, cela donne:

./geogebra 
GeoGebra 5.0.680.0 08 December 2021 Java 17.0.1-64bit

11:30:17.978 DEBUG: org.geogebra.desktop.j.a.<init>[-1]: runningFromJar=true
11:30:17.978 DEBUG: org.geogebra.desktop.j.a.aC[-1]: Setting up logging
11:30:17.999 DEBUG: org.geogebra.desktop.j.a.aC[-1]: Logging is redirected to /tmp/GeoGebraLog_ttqowsmxci.txt
Inconsistency detected by ld.so: dl-lookup.c: 105: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

Une idée?

merci

1 Like

Bonjour !

Quels sont les paquets Java que vous avez ?

pacman -Q | grep jre

J’ai jre-8.

jre8-openjdk 8.u312-2
jre8-openjdk-headless 8.u312-2

Si vous installez à partir de “AUR”, vous n’avez pas d’erreur.

J’ai installé geogebra-5, et il se lance. La version est la même que la vôtre.

yay -S geogebra-5

De mon côté

$ java --version
openjdk 17.0.1 2021-10-19
OpenJDK Runtime Environment (build 17.0.1+12)
OpenJDK 64-Bit Server VM (build 17.0.1+12, mixed mode)

J’ai différents.

[lain@wired ~]$ java -version
openjdk version "1.8.0_312"
OpenJDK Runtime Environment (build 1.8.0_312-b10)
OpenJDK 64-Bit Server VM (build 25.312-b10, mixed mode)

Veuillez essayer d’utiliser “openjdk”.

Exécutez cette commande

yay -S jre8-openjdk

Puis lancez Geogebra.

1 Like

yes!

archlinux-java status
Available Java environments:
  java-11-openjdk
  java-17-openjdk (default)
  java-8-openjdk/jre
(base) [jeanpat@T430 ~]$ ^C
(base) [jeanpat@T430 ~]$ geogebra
Run with exported java-8-openjdk
GeoGebra 5.0.680.0 08 December 2021 Java 1.8.0_312-64bit

14:49:30.950 DEBUG: org.geogebra.desktop.j.a.<init>[-1]: runningFromJar=true
14:49:30.950 DEBUG: org.geogebra.desktop.j.a.aC[-1]: Setting up logging
14:49:30.960 DEBUG: org.geogebra.desktop.j.a.aC[-1]: Logging is redirected to /tmp/GeoGebraLog_qbbdszpbfo.txt

merci beaucoup

1 Like

Bienvenue !

J’étudie le français et je suis content pour comprendre les textes en français.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.