Gemini Installer using ext4 even though brtfs is selected

Greetings,

First forum post but I’m starting my journey with EndeavourOS to try out the Arch ecosystem. Likely not my last…

I’m installing to a late 2013 Macbook Pro dual booting along side MacOS. I resized the APFS partition within MacOS to accommodate about 66GB for Linux. Booted into the Gemini live USB I created and manually removed the 66GB APFS partition with gparted so it read as unallocated space. During the install I had selected Replace a partition -> btrfs -> Encrypt system checked with password and selected the unallocated space. I had selected systemd-boot as the bootloader that sat on it’s own 1GB EFI partition.

No real issues. Install completes and the bootloader worked. I tinker around with the package manager and the desktop environment for a couple days just to familiarize myself. Then I start looking into setting up snapper or timeshift. Ended up realizing that the install did a LUKS2 partition that was formatted as ext4 even though I thought I selected encrypted btrfs. No biggie I’ve not really done anything of value on the OS to not redo the install and figured was probably something I overlooked anyways.

Today I boot up the same Gemini USB and start navigating through the install. I manually removed the 1GB EFI partition used by systemd-boot and manually removed the LUKS / ext4 partition so it was unallocated space. I wanted to try using Grub for booting into snapshots this time though. When I select Replace a partition -> btrfs -> Encrypt system checked w/ password and I navigate to the Summary page it indicates it is going to flash as ext4 again. I used spectacle to take a couple screenshots of what I’m seeing:


Curious if this is a known issue or do you see anything I’m glaringly wrong on?

I’m considering manually partitioning the fat32 EFI and the encrypted btrfs partitions. Will the installer create the btrfs subvolumes as outlined in the /etc/calamares/modules/mount.conf file if I do or is that something I have to do manually afterwards? This will be my first time using btrfs.

Thank you

That is strange. I would check and make sure the filesystem box isn’t changing after you select the partition to replace.

Yes, if you set a btrfs filesystem with a mountpoint of / it will get those subvolumes.

Thanks for the reply.

Seems to have been a weird bug. Not sure it’s important enough to investigate though. I reloaded the installer application and rebooted a few times every time doing this order once I got to the Partitions window:
1.) Replace a partition 2.) btrfs 3.) click the unallocated space I wanted to format 4.) Hover over the change and it would always show ext4. Default it would select the existing 200M EFI partition installed by MacOS in /dev/sda1. Even if I would select New EFI and hover over the change it would still show ext4.

What ended up working for me was the following once I got to the Partitions page:
1.) Replace a partition 2.) btrfs 3.) Click the APFS partition I was keeping 4.) Hovered over it and it showed btrfs 5.) click the unallocated space 6.) Hovered over it and it still showed btrfs 7.) Selected New EFI partition 8.) Hovered over it again and still read btrfs. At summary page it remained btrfs.

I’m booted into the fresh install and when I run sudo btrfs subvolume list / it shows the subvolumes as populated ( custom or default ) from the USB /etc/calamares/modules/mount.conf file.

and… welcome to the purple fun :enos:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.