GDM doesn't show when booting

Hi guys,
old arch and new endeavour user here.
I’m loving the distro but I’ve a little problem that I cannot manage to solve.
Basically I’ve installated Endeavour and Gnome and when I boot up the system all goes well except that the screen remain black and nothing else happens.
If I switch to another tty and then back to tty1 (without doing anything else), then GDM show up and I’m able to login. Everything work fine other than that. I’ve a Dell Inspiron with and Nvidia discrete card but I’ve not installed propretary driver yet (and I’ll not because I need does for HW passthrough during virtualization).

Thanks everyone for your time.

  • PN

Welcome aboard!

I have never experienced this problem, so this is a stab in the dark.

# systemctl status gdm.service

if it isn’t enabled

# systemctl enable gdm.service 

This should create a symlink if it wasn’t enabled

If that doesn’t fix it. we will need more information from you.


Thank you. I’ll try this evening and report. Another problem that I noticed last night and I think could be related. When shutdown or reboot, either from GUI or console, the system hangs on black screen and I have to force shut it down. On reboot there is no need for journal cleaning tho, so I think the system actually shutdown correctly at least almost to the end.

  • PN

See this post in another topic. This may fix it.



Sadly none of the above ideas works, not even the reported solution for the reboot/shutdown stuck.

actually found the solution in an “old” (September) Archlinux forum thread. Basically the solution is to add i915 (if like me using Intel) or amdgpu or nouveau to the “module” section in mkinitpcio.conf and than rebuild the image.
Doing that solved (seems) the startup and the reboot/shutdown issue.
Basically that happens because the graphic card is not ready when gdm is called and so it wait for another one before starting correctly. Adding the module to the init image ensure that they are loaded at the right time.

Now my question is: shouldn’t they already be there when installing?

Thanks for the help anyway.