Fstab setup on Arch

I noticed that couple flags were different on EOS vs my Arch installation that I’m messing around with.

Is my current FSTAB entry okay or need to add additional flags? Such as, autodefrag defaults.

I am using SSD and latest kernel on BTRFS. Its just one drive.

UUID=1ae3f2e6-288d-4747-8e73-6e8d74c20347	/         	btrfs     	rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,subvolid=256,subvol=/@	0 0

# /dev/sda1
UUID=69DE-AC58      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/sda2
UUID=1ae3f2e6-288d-4747-8e73-6e8d74c20347	/home     	btrfs     	rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,subvolid=257,subvol=/@home	0 0

# /dev/sda2
UUID=1ae3f2e6-288d-4747-8e73-6e8d74c20347	/var      	btrfs     	rw,noatime,compress=zstd:3,ssd,discard=async,space_cache=v2,subvolid=258,subvol=/@var	0 0

Many Thanks in advance.

What you have is fine. Those options are a matter a preference to some extent.

Personally, I would remove space_cache=v2 since that it the default. On the other hand, it is fine to leave it.

If you aren’t doing periodic trim or you run your disks near capacity then discard=async is good. If the opposite is true, you probably don’t need that.

thank you Dalto.

Any reason to include autodefrag ? I do have systemctl enable fstrim.timer which i believe trim weekly.

I would not enable that on an SSD.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.