Front panel Audio Not working(Solved)

Hi
I am using Endeavour OS from Dec’2019. When i installed,I haven’t checked front panel audio because ports are not in working condition.
Now i changed the cabinet and now the ports are working, However whenever i connect headphones, i have to open alsamixer in terminal, change sound card from Default to HDA Intel and un-mute headphone to hear audio through headphones. i tried to save it using sudo alsactl store command but it is not working when i restart the system. my system info

"System:
Kernel: 5.6.14-arch1-1 x86_64 bits: 64 Desktop: Cinnamon 4.6.1
Distro: EndeavourOS
Machine:
Type: Desktop Mobo: N/A model: N/A serial:
BIOS: American Megatrends v: 080015 date: 03/11/2017
CPU:
Topology: Dual Core model: Intel Core2 Duo E4500 bits: 64 type: MCP
L2 cache: 2048 KiB
Speed: 1339 MHz min/max: N/A Core speeds (MHz): 1: 1339 2: 1541
Graphics:
Device-1: Intel 82945G/GZ Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.8 driver: intel
unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel NM10/ICH7 Family High Definition Audio
driver: snd_hda_intel
Sound Server: ALSA v: k5.6.14-arch1-1
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
IF: ens32 state: up speed: 100 Mbps duplex: full mac:
Drives:
Local Storage: total: 149.05 GiB used: 38.61 GiB (25.9%)
ID-1: /dev/sda vendor: Seagate model: ST3160215AS size: 149.05 GiB
Partition:
ID-1: / size: 16.18 GiB used: 12.67 GiB (78.3%) fs: ext4 dev: /dev/sda8
Swap:
Alert: No Swap data was found.

Info:
Processes: 152 Uptime: 6m Memory: 3.41 GiB used: 887.8 MiB (25.4%)
Shell: bash inxi: 3.1.00"

Is there anyway i can save the alsamixer settings to be used on subsequent restarts or am i missing something here.

This describes how I got a script running at boot if that would help you.

Thanks for this. Its a good work around. I will definitely try this if no ther direct solution is suggested.

https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#ALSA_and_Systemd

ALSA and Systemd

The alsa-utils package comes with systemd unit configuration files alsa-restore.service and alsa-state.service by default.

These are automatically installed and activated during installation (via package provided symlink to sound.target). Neither will run by default, as they rely on some conscious decisions by the user to know which method should be preferred. The options are as follows:

  • alsa-restore.service Reads /var/lib/alsa/asound.state on boot and writes updated values on shutdown, granted it is already present by having ran alsactl store at some point
  • alsa-state.service (Re-)Starts alsactl in daemon mode to continouously keep track of, and persist, volume changes, again under the condition that the user has consciously started alsactl daemon at least once

Both methods are mutually exclusive and you can decide for one of the two approaches depending on your requirements, for further information see alsactl(1)

You can check their status using systemctl status alsa-restore.service or systemctl status alsa-state.service

start and enable one of them:
sudo systemctl enable --now alsa-state
or:
sudo systemctl enable --now alsa-restore

Hi Joe,
Thanks for this, It is working now.

1 Like