Fresh EndeavorOS install hangs while loading initramfs on new MSI Alpha 15 laptop

I actually tried installing pure arch first, several times, before using the EndeavorOS installer. When using the EndeavorOS installer I chose to erase the disk to start fresh and selected all of the default options in the installer. Everything worked until I rebooted, when it hangs while loading initramfs the same as it did during my arch linux install attempts.

Here is what I’ve tried so far:

  • Installing Arch from scratch, following the installation guide, at least three separate times.
  • Mounting the efi partition (flagged properly) as /boot
  • Mounting the efi partition as /boot/efi (and copying the kernel etc. to that dir).
  • Installing grub with microupdates.
  • Installing grub without microupdates.
  • Installing systemd-boot with microupdates.
  • Installing EndeavorOS without changing any settings.

All of these resulted in the same behavior mentioned in the title.

After I bought this laptop I installed a Samsung 970 pro evo ssd (1TB) nvme as my only disk, a linux-friendly wifi card, and 64gb of quality ram. The laptop booted right up to Windows 10 upon receiving it, so I’m sure I didn’t get a lemon.

How would I go about troubleshooting what’s wrong? When it halts it seems as though the instruction set hits a dead end. No keystrokes register, all I can do is hold down the power button until the device powers off.

I find this strange because the arch usb iso boots fine with two errors indicating missing firmware for this specific laptop’s backlighting controls and one other non-critical feature. By the way, I also compiled the missing kernel modules for these, installed them, and re-ran mkcpio which added support for those features and removed the errors.

I’m fairly technical and I use a bsd variant (MacOS X) every day at work, but I’ve never had to troubleshoot a problem after POST but before/as the kernel is loaded.

Any suggestions? Thanks in advance!

I wonder if the error is related to your gpu. I’m not familiar with the Radeon family, so I hope someone with more knowledge will chime in.

I do have a few questions off the top of my head, though: 1) Did you disable secure boot? 2) Are you positive you’re booting using uefi and not legacy during installation? 3) Have you tried and succeeded installing other Linux distros?

1 Like

Hi sothis6881, thanks for the reply!

It’s VERY possible that my gpu is the culprit. This laptop has the very latest AMD mobile graphics card (which was the main reason I bought it, so I can run wayland natively and flawlessly).

I did disable secureboot as well as quickboot, and I disabled tpm as well at one point as per a different forum post I read while researching.

I actually tried both uefi and legacy booting. For legacy I created a bios boot partition (1M) and it fired up fine until initramfs. I didn’t try MBR because I have concluded that finding the boot files isn’t the issue.

I am about to try installing some vanilla distro that should work no matter what, i’ll post my findings after I finish the install.

Just a hunch but I have seen posts around many times with people having trouble when using the erase disk option in calamares. Did you try to manually format and then set up the partitions that way? I believe the default format is msdos and you will want GPT. This is obviously a UEFI laptop. Anyway can you try:
Disable CSM if necessary.
1.Run the installer.
2. Format the drive as GPT
3. Partition 1-512mib fat32 mounted at /boot/efi with the boot flag set.
4. Partition 2-32Gib ext4 mounted at / (not /root they are different).
5. Partition 3-rest of the drive ext4 mounted at /home. I don’t think you need swap with 32Gib ram. Separate /home is a good idea if not step 4-5 can be substituted with / as the rest of the drive.

1 Like

Unless you want to use hibernate instead of suspend.

1 Like

Thank you for correcting me @sothis6881. I forget that as I do not use hibernate :+1:

Elloquin/sothis6881,

Yes, I actually started with a custom partition scheme for uefi boot, everything worked until it got to initramfs. Same for my legacy attempt, only that used a gpt partition scheme with a fat32-formatted bios boot partition alongside a root partition and a 32gb swap. Same result.

1 Like

Hi @fenreer, could you try to follow the wiki below and redo your GPT scheme with GPARTED, you have it by default on the Live EOS :

To avoid problems, you can make a partition scheme by using Gparted before you start Calamares

I have a positive update. After reading re-reading the first response here I decided to try booting endeavor again after double-checking that secureboot was disabled in bios. It was enabled, which really puzzled me. I messed around in the bios a bit and discovered that it automatically resets all boot settings to default whenever you change your preferred boot scheme (legacy, UEFI, etc.). Following this discovery I once again disabled secure boot and re-checked that the value I set had been saved, then rebooted once more. This time I booted straight into a shell prompt. :smile:

2 Likes

You could give the solution to @sothis6881 !
That’s possible you don’t still master this Discourse forum, don’t worry, we all had to get time to use it as well…

Great you got it work, your machine seems to be good for it.

Welcome to EndeavourOS :rocket:

1 Like

Glad to hear you got it sorted out :smiley:

1 Like

For anyone searching who finds this post, the solution for me was disabling secureboot in bios – and realizing that changing the boot scheme in any way (such as from UEFI to Legacy) reset all boot settings in my bios, requiring me to once again disable secureboot.

2 Likes

They REALLY want to make sure you stay “safe” :wink:

1 Like