Freezed display on live ISO

Hello! I wanted to install EOS, but I’ve encountered a bug which blocks me through the installation.

Xfce get suddenly frozen, then there is a black screen, then it comes back a few second laters, still frozen. But it’s only visually, the mouse cursor still changes if I move it to an input field, or to the terminal. But everything is visually frozen.

I noticed it happens when Calamares is opened. I tried to reproduce it without it, but maybe it was bad luck. I also noticed it happens when I’m typing in an input field : it happened two times on firefox, an other time when I entered my username during the install. When it’s frozen, there’s a graphic glitch in the input I was typing in:

Is there something I can do ? Maybe flashing my bios?

Thanks for your help.

My hardware configuration :

  • CPU: AMD Ryzen 5 3600
  • GPU: Radeon 6700 XT
  • RAM: 2 x 8 GB DDR4-RAM, 3200 MHz, (Kingston HyperX Fury BLACK Series)

Edit: more details on my configuration :

Welcome to the :enos: forums.

It seems your graphic driver is crashing. Would you be able to run this command inxi -Fxxc0z --no-host | eos-sendlog in your live environment and then post back the link here.

It would help the community to look at the hardware setup in detail and help you more effectivly.

1 Like

Hello s4ndm4n, I’ve updated my post and put the link at the bottom :slight_smile:

these motherboards seem to have an issue with such freezes caused by Network chips.

And in addition the one on your board can cause Network issues and needs to change driver in some cases:

Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

Do you got a popup asking for changing driver?


Indeed, when enter in the live ISO, I’ve a pop-up telling me there may be some problems with some network driver. I picked the (default) choice, but I’ll try with the the older one as soon as I can and keep you informed.
Thanks for your help!


Hi again!
So I’ve tried with the r8168 drivers instead of the r8169, and… same problem.
As long as Calamares is not running, it’s fine, but when I start the install process, it freezes relatively quickly.
I suppose it comes from the graphic drivers, as s4ndm4n suggested it :frowning: .

(very) dumb question : can I update the graphic drivers in the iso before starting Calamares ?
Or should I try with an other installer? (If there’s one available for EOS).

Again, thanks a lot for your help!

I don’t think you can. @joekamprad would clarify more. But we don’t advise updating the live system because it might break the installation process.

1 Like

the solution would be to not use the lan port and disable it in Bios/Firmware and for install using USB tethering or wifi adapter.