Flatpak app shorcuts are beeing not registered for plasma launchers

this problem can be demonstrated by doing a:

flatpak update

then I get:

**Note that the directories **


are not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

I did google a lot but no luck so far, edited and also deleted xsessionsrc with
export xdg lines, reinstalled gsettings-desktop-schemas ( for whatever reason gsettings is related to that ? ), reinstalled flatpak

has anyone an idea to help out. (please:-))

Try a full reboot then see if the icons appear.


1 Like

preferably it should go automatically at install, but even after a restart, the menu is not completed with the flatpak apps.

That should be handled by /etc/profile.d/flatpak.sh which is part of the flatpak package.

Are you overriding XDG_DATA_DIRS somewhere?

What shell are you using?

no so far I know do not override meaning the /etc/envireoment, i gues you mean, that file is empty…

i recently changed to FISH shell

The fish shell is probably the issue here. I am not that familiar with it but it if it doesn’t read all the files in /etc/profile.d you will have to do the things that /etc/profile.d/flatpak.sh and /etc/profile.d/flatpak-bin.sh does yourself.

1 Like

I also have a flatpak-binddir.sh in /etc/profile.d… with that content:

  # set XDG_DATA_DIRS to include Flatpak installations

I second that. At this stage, it’s better to “exec fish” from a fully ready BASH session rather that switching to FISH full time.


Indeed. Do not chsh your user’s shell to anything other than Bash, you’re just setting yourself up for strange, difficult to troubleshoot problems. Especially do not set it to a non-POSIX shell like Fish.

Just have your terminal emulator launch whatever interactive shell you want. I use Zsh, but my user’s shell is Bash.

1 Like

I actually do change my shell to zsh. But there is a big difference between zsh and fish from a POSIX-compliance standpoint.

Same here. I actually like ‘fish’ and use it extensively for my interactive sessions but their decision not to support POSIX just blocks me from switching fully in.

It’s probably harmless, but I really see no point in doing that.

99% of the time I use Zsh, as I have it set in Konsole for my default profile. But when I use a TTY, I don’t need any fancy Zsh features (in fact, I find them getting in the way), and Bash is completely sufficient.

uninstalled fish now I cannot login anymore not even tty :shushing_face:

password fails

Did you change your shell before uninstalling?

If not, login to a TTY as root and switch your users shell back.

Login as root, and chsh your user’s shell to Bash.

1 Like

I do :cowboy_hat_face:

I make pretty heavy use of completions and zmv. Plus all my ease of use functions are in my .zshrc

1 Like

you are right I forgot chsh :shushing_face:

now is login incorrect on any tty and any user incl. root

You changed root’s shell to fish? You should never change root’s default shell.

If that is the case, you need to boot off an ISO, mount your root partition and edit /etc/passwd manually(and carefully) to fix the shell.

must have done it, what a shame … now I am on liveCD