Flash drive is hard to mount on EOS

I have a SanDisk Ultra USB 3.0 flashdrive, and it is formatted to NTFS. If I remember right, I formatted it on Ubuntu.
When when I am running EOS, and I insert it, I cannot mount it from my file manager.
It fails with the error

Error mounting /dev/sdf1 at /run/media/shmuel/Sandisk 256: wrong fs type, bad option, bad superblock on /dev/sdf1, missing codepage or helper program, or other error

I need to run the “mount” command in terminal in order to mount it.
But it mounts automatically on MX Linux (a Debian based distro).
I am puzzled why the almighty EOS can’t do it, if MX can.

inxi -F
System:
  Host: endeavouros Kernel: 6.7.0-arch3-1 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.10 Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B365M-A v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2208
    date: 07/09/2021
Battery:
  ID-1: hidpp_battery_0 charge: 52% condition: N/A
CPU:
  Info: 8-core model: Intel Core i7-9700 bits: 64 type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 2650 min/max: 800/4700 cores: 1: 800 2: 4501 3: 4501
    4: 4499 5: 800 6: 4500 7: 800 8: 800
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: USB C Video Adaptor driver: N/A type: USB
  Device-3: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  Display: wayland server: X.org v: 1.21.1.10 with: Xwayland v: 23.2.3
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: vesa
    dri: iris gpu: i915 resolution: 1: 1920x1080 2: 1920x1080
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-arch1.1
    renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
  Device-2: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  API: ALSA v: k6.7.0-arch3-1 status: kernel-api
  Server-1: PipeWire v: 1.0.1 status: active
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:e2:87:3c
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s20f0u3u1 state: down mac: 00:e0:4c:68:51:92
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    type: USB
  Report: btmgmt ID: hci0 state: up address: 00:1A:7D:DA:71:13 bt-v: 4.0
Drives:
  Local Storage: total: 2.26 TiB used: 830.49 GiB (35.9%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD120 size: 1.82 TiB
Partition:
  ID-1: / size: 82.1 GiB used: 23.08 GiB (28.1%) fs: ext4 dev: /dev/sda7
  ID-2: /boot/efi size: 96 MiB used: 50.6 MiB (52.7%) fs: vfat
    dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 298 Uptime: 16m Memory: total: 16 GiB available: 15.49 GiB
  used: 5.98 GiB (38.6%) Shell: Zsh inxi: 3.3.31

It depends on what you have setup/running. KDE detects insertion and asks if you want to mount it.
It’s not an EOS choice/fault.

NTFS is not a linux file system. You probably need this:
Arch Linux - ntfs-3g 2022.10.3-1 (x86_64)
It was probably included on other distros but not here as they try to keep things unbloated.

This would be because they are two very different systems. Mx is based on what debian / ubuntu on of those and EOS is Arch.

that seems to be a common thing with NTFS. I suspect something doesnt like the way it was last unmounted.

I have “ntfs-3g” installed.
The flash drive is automatically detected but I get the error mentioned in the OP.
The error persists even if I manually mount it by terminal, remove it, and then reinsert it.

I would experiment with adding an entry for the flash drive in /etc/fstab using the UUID of the NTFS partition with nofail added to the mount options.

Have a look here for what other mount options you would need to add for having Linux compatible permissions on that partition

https://wiki.archlinux.org/title/NTFS-3G#Linux_compatible_permissions

Check if this would help mounting it from your file manager.

Would exFat be a better option instead of ntfs?
exFat has native kernel support as of 5.4 so compatibility should be good

Yeah, I will probably reformat the flash drive when I get around to backing up the data. Just wondering if I am missing a package or doing something wrong or what.

NTFS is apparently still problematic with Linux. I see issues with it more often than one expects. I haven’t used NTFS in over a decade but remember it didn’t always do well under Linux

The kernel has ntfs support, so ntfs-3g package should no more be needed.
In /etc/fstab (and with the mount command) you’d use type ntfs3.