Fixing Broken QT App themes in Gnome

So for a while now Ive been having the issue of broken QT Apps running on gnome when not a flatpak. This would cause the applications to be mostly white and unusable, so i finally went about figuring a way to fix it. If you have this issue try this. I couldnt get qgnomeplatform to work with this and had to swap to kvantum.

1.First you need to uninstall

sudo pacman -R qgnomeplatform-qt5 qgnomeplatform-qt6

2.Then install kvantum

sudo pacman -Syu kvantum

  1. set the QT style override either in /etc/environment for global or ~/.bashrc for per user by adding this line

export QT_STYLE_OVERRIDE=kvantum

3.5 You can do this per app with adding this to the launch options

env QT_STYLE_OVERRIDE=kvantum

This fixed kdenlive which had become almost completely broken for me and also weird theme issues in OBS-Studio.

One thing to consider is that kvantum won’t theme qml applications while qgnomeplatform does.

You may just be trading one problem for another.

1 Like

Well in my case with qgnomeplatform the only functional QT application i had was obs-studio but it had some really bizarre theme issues. This was the only thing that fixed it for me outside of being forced to use flatpaks for anything QT.

EDIT: now that i think about it i believe it began with the introduction of libadwaita

Edit2: This was similar to my issue except everything but the 2 video previews and a couple buttons was white when using qgnomeplatofm

you can stil use qt5ct and adwaita, and select adwaita-qt and install that style also from repo :slight_smile:

Thanks!

Installed Gnome and Budgie yesterday and this is exactly what I’m looking for XD

removed gnome

1 Like