Fix for EndeavourOS getting stuck after login screen

I am a newbie to Endeavour who just started today! I know the title might sound similar to other posts but it is not, anyway, I installed the OS through the live media. After I restarted and logged in, I could see and move the mouse but I was not able to see any buttons on screen or any UI, except! the wallpaper. I was kind of confused why I got nothing? I remember Endeavour installing bspwm with the common packages too… I thought this was the default and continued… I think Endeavour started bspwm? even though I wanted to install the normal system. A few more details too… I did not see and options to select my DE like shown in many tutorials (I planned to install Xfce), also my laptop is pretty old, I mean PRETTY old. around 10 years, Hence I switched to linux (I chose arch but difficult to install :confused: )
If you need my specs here they are:
500 GB hdd
2 GB ram
HP compaq
This is my first upload so it might not look good :stuck_out_tongue:

1 Like

Press Super+Enter (Thinks that is it!), Do you get a terminal?

Which Desktop do you want?

Ah yes, I have tried! I (at first) also thought Endeavour opened bspwm, as I had some experience in i3 before, I tried just that, but in vain…

  • This will limit usage of Browser a lot, so make sure creating Swap with around 4GB at minimum.

If you remember to choose BSPWM you start installing Community Editions so default options are not available. (as the Text in the Windows show you also, and the release info :wink: )

Choose the left top install button to install default versions if you want to take EndeavourOS default XFCE4 take the offline option (will give you a fast install and themed XFCE4 Desktop)

1 Like

Can you get a tty? Ctrl+Alt+F2

If I remember correctly, yes, Endeavour automatically gave me around 4.x GB swap :slight_smile:

Let me try that real quick

sudo pacman -S xfce4 xfce4-goodies

Will install a basic xfce, but if you have just installed, I would reinstall as suggested by @joekamprad

actually I did get a tty! :smiley:

Sadly trying to run the live media again just reboots after showing
running vimlinuz or something along those lines… is that normal?

If choosen BSPWM Community Edition and having no Bar after login looks like theming and setup missing, so a blank BSPWM (pretty useless… )
The only thing you could do is getting the setup files in from GitHub:

git clone

cd bspwm

1 Like

This did not work at all!! This gave me around a million errors saying failed retrieving file xxx

You have no internet, let me try and dig up the instructions…

no internet connection :wink:
nmcli dev wifi connect "SSID" password PASSWD
SSID your networkname and PASSWD the wifi password

1 Like

OOF. i forgot

In quotes? or without them

Thanks Joe, been a while since I needed to do this, if nmtui is installed it may be easier to use.

should not be that… i would go to simply reinstall with default offline XFCE if you can get ISO to boot up.

1 Like

It says wlan0 successfully connected with xxxxx-xxx-xxxxx

1 Like

Sadly the live media ISO just doesn’t want to start up again >:(