First time installed EndeavourOS and the Display glitching

Hi everyone, I’m a new Linux user who tried out Manjaro 1 month and now switched to Endeavour OS.

But I have one problem, after fresh installed i3wm (dual boot) I have graphical glitches. I don’t know what caused the problem, but this makes my eyes hurt

Hei @Ares welcome here…
As far as you do not give any information on the hardware in use, we can only call the magic glassball :wink:

  • Login Screen was looking the same?
  • rebooting do not solve this?
lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | eos-sendlog 

will give a short URL with you system specs and boot log all together you can post here.
If not possible try to give info about Graphics CPU e.t.c.

1 Like

You need to install the LTS kernel, this will solve your problem.

Excuse me for the lack of information and how stupid I am. I have Acer Predator Triton 300 with those spec:

  • Intel Core i5-9300H (with Intel iGpu)
  • Nvidia GTX 1650m (with proprietary driver no legacy)
  • 16GB RAM
  • SSD 512GB

After I give it 1 hour afk somehow the screen is back without any graphical glitches, I thought the issue has gone so I am happy for a moment, so I copy pasted command lines you gave me but the terminal said eos-sendlog command not found.

I reboot, now stuck on these lines


Then I tried force shutdown after waiting for 10 mins. Turning on the machine again well… the result is back to zero again. I got the graphical glitches everywhere. Oh yeah forgot to mention the login screen looks the same. :slight_smile:

Welcome to the forum! :smile:

If you can boot with the USB installer, then you can arch-chroot into the installed system and make some changes.
See more in https://endeavouros.com/docs/system-rescue/rescue-non-booting-system-with-arch-chroot/

When you are successfully in the installed system with arch-chroot, you could try uninstalling package xf86-video-intel. Some (usually newer) systems don’t need that video driver, but others do.

If you are not familiar with pacman (the package manager), see here: https://endeavouros.com/docs/pacman/pacman-basic-commands/

If eos-sendlog is not installed, please install it with terminal command

  sudo pacman -S eos-bash-shared

But that should always be installed in EndeavourOS… unless you removed it … or there was a typo in the command.

on latest ISO it should be installed or not?

Yes, by default it is.

This looking very likely like a hybrid dual GPU system?
So could be it needs some setup on what to use per default.

2 Likes

Hello I’m back!
I’m sorry for the late respond but here I am.

After I look @joekamprad latest replies I checked that the hybrid graphics are not installed by default, so I open up terminal and installed optimus-manager and the display came back to normal, thank you for helping me :grinning: I love Endeavour OS everything comes out-of-the-box aside from the issue I have

Oh yeah about the eos log, I think it was my fault for mistype commands whoops. Here’s the log
http://ix.io/20T0
http://ix.io/20TR

@manuel I already know some basic terminal and pacman commands but thx for the help too. Sorry for my bad english :slightly_smiling_face:
@Lemon I want to gaming on my Linux OS so I have to stay in the bleeding edge :slightly_smiling_face:

2 Likes

Your English is perfectly understandable. :smile:

1 Like