Firefox won't launch

Hi, I’ve been using bspwm for 6 years now. Decided to try a preconfigured edition. Initially, wifi did not work and some other apps. Reinstalled and everything worked. Launched firefox and then closed it. Now it will not launch using key command or rofi. Any suggestions would be appreciated.


Try launching it from the terminal and see if any errors show up there

1 Like

dalto: thanks for the reply. I had tried that and it appears to be launching but doesn’t. No error messages.

I wonder if it could have something to do with “corrupted” profiles in .mozilla.

You could perhaps rename the folder and try starting Firefox afresh.

1 Like

pebcak: thanks for the reply. Tried that but did not work. Now I have removed firefox and trying to reinstall.

1 Like
firefox --ProfileManager

Create a new, clean profile.

otherbarry: thanks will give it a try.

I reinstalled firefox and so far its launching. If it stops, I will try building a new profile.

thanks for all the replies.

This implies you have a failing hard disk or faulty RAM - do a disk health check and memory test.

1 Like

This “happened” to me. Tried to launch but nothing happened, and I remembered seeing this post here and got worried for my trusty ol’ Dell’s RAM / HD. This was before I found the keybindings file and discovered Super + Tab, which took me to a desktop brimming with Firefoxes :monkey_face: Well, that’s what happens when you dive head first into something you don’t yet quite understand…
(EDIT: just speaking for myself, not imlying this is what happened to OP)