Firefox often crash on Plasma6.1 nVidia555beta

[v1n1@ttt ~]$ firefox
[GFX1-]: Wayland protocol error: wp_linux_drm_syncobj_surface_v1#54: error 4: explicit sync is used, but no acquire point is set

ExceptionHandler::GenerateDump cloned child 290811
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
[v1n1@ttt ~]$

Very oftenly when I browse Firefox just quits, opens crashreporter, and when I press restart (and autosend error to Mozilla), it restarts and quite in a minute quits again.

Happens mostly when browsing between pages. Most of the time doesn’t crash when watching youtube stand still.

Started happening as soon as I updated to Plasma 6.0.5->6.1

All is fine for me. I’m also on 555 drivers with my 3080. Firefox only crashes if kwin crashes for me.

1 Like

Are you using the environment variable?

MOZ_ENABLE_WAYLAND=1

Posssible solutions here maybe?

https://www.reddit.com/r/linux_gaming/comments/1cxhxja/is_anybody_elses_firefox_crashing_with/

1 Like

i think firefox has this enabled by default for some time already:
https://wiki.archlinux.org/title/Firefox#Wayland

1 Like

Yes i forgot about that. :upside_down_face:

1 Like

I followed your hyperlink and

$ MOZ_ENABLE_WAYLAND=0 firefox

This works.


So solution for now are appending line:


MOZ_ENABLE_WAYLAND=0

to kate /etc/environment and reboot. Until this fixed:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.