Firefox launches on startup for no reason

Lately Firefox has been launching on startup for no identifiable reason. I’m running all the latest packages and firefox 111.0-1 with KDE. There is no Firefox entry in System Settings > Autostart and I cannot find anything about it in Firefox’s own settings. Any and all help is appreciated.

Neofetch dump:

                     ./o.                  runarcn@endeavour 
                   ./sssso-                ----------------- 
                 `:osssssss+-              OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: 20X2S0DL00 ThinkPad L14 Gen 2 
             `-/ossssssssssssso/.          Kernel: 6.2.7-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 3 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1267 (pacman), 6 (flatpak) 
       `.://osssssssssssssssssssso++-      Shell: bash 5.1.16 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.27.3 
  `:////ssssssssssssssssssssssssssso+++.   WM: kwin 
`-////+ssssssssssssssssssssssssssso++++-   WM Theme: Breeze 
 `..-+oosssssssssssssssssssssssso+++++/`   Theme: [Plasma], Breeze [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Icons: Papirus-Dark [Plasma], Papirus-Dark [GTK2/3] 
  `:::::::::::::::::::::::::------``       Terminal: konsole 
                                           CPU: 11th Gen Intel i3-1115G4 (4) @ 4.100GHz 
                                           GPU: Intel Tiger Lake-LP GT2 [UHD Graphics G4] 
                                           Memory: 2223MiB / 7598MiB 

Session restore setting maybe?

1 Like

If you haven’t already done this, check here too:

1 Like

This seems to have been it. Thanks! ^-^

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.