Firefox gesture control doesn't work

So the new Firefox 106.xx should support swiping right to go back one click on the browser (or navigate back if you like). Like going back after clicking a news link. However it does not do that for me (GNOME DE). LinuxEXP had a short toot about this in the latest build of FF (which we have).

When I check the about:config in the FF settings, there are no settings present (other than scroll).

I did find one thread where gesture control didn’t work on a Mac, but that was resolved by placing (or moving) a file into a specific folder (can’t remember that now, closed the tab).

Looks like these are the keys you should be looking for:

Screenshot from 2022-11-09 22-25-36

Also perhaps this article might be useful:

I was actually checking this out, but none of these settings are present.

I have no idea how to add them into my browser, plus I thought it was enabled by default in the latest build.

Yes, it should have been. It’s quite strange that the keys are not present at all.

Screenshot from 2022-11-09 22-33-36

In the “search bar” at the top of about:config type:
browser.gesture.swipe.left.
Choose string and and click on +.
Type: Browser:BackOrBackDuplicate in the box and click the check mark.

Do this also for:
browser.gesture.swipe.right
Browser:ForwardOrForwardDuplicate

Also make one for
browser.swipe.navigation-icon-move-distance
and this time choose number and give it a value, like 10, to begin with.

Restart your browser.

Not sure if this will work but worth a try.

I have this as so
mynd

No can’t add anything. I didn’t have any hotkeys. I was able to choose on “gesture.enable_single…”, but I didn’t move the selection to string before pressing the + button.

Going to see if I can’t reset that.

Just try and copy-paste what I wrote above and see if you get to choose between Boolean, Number or String.

After resetting about:config, I tried your method. By choosing “string” I am able to make one command. ONE! But I have no ability to add another… this is highly frustrating (FF).

Not sure how things are on your end but in principle there shouldn’t be any restrictions on how many keys you could add.

I have no idea. I haven’t changed anything, just updated FF and happy trucking. This is literally the options I get
mynd

I have no idea… except maybe uninstall FF and delete all containing folders and then install it again…

Not sure why you keep typing gestures into the search bar.

You need to paste in the keys with the exact wording as I posted above.
And do the rest to create a string etc.

Just added three keys for demonstration
Screenshot from 2022-11-09 23-07-18
:

I actually didn’t think of that, I thought I had to type everything in after pressing “add” button…

I guess I am getting old :older_man:

1 Like

BUT in my opinion, this should be on by default :smiley:

1 Like

Did you get it working ?

No
:laughing:
Tried closing FF and opening it again after enabling the gestures I want… have no idea what is happening

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.