FireFox fonts are driving me crazy

I made a little install to try Cinnamon and MATE (I’m a KDE guy), and ever since I changed the themes to Ark-Dark on Cinnamon, the FF Fonts are very hard to read. I tried to change them from within FF, but it doesn’t seem to make a difference. Anyone had this issue before? Is there a reset to defaults in Cinnamon anywhere?
I’ll take a screen capture of this so you can see what I mean.

Hmmm,seems pretty normal to me.

Some lines are thinner, others fatter.

Look at the letters of your first word.

  1. Exit Firefox
  2. Create symlink to activate lcd filter
    sudo ln -fs /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/
    
    fc-cache --force
    
  3. Launch Firefox

If it helps, all thanks goes to stupid new defaults for fontconfig. which doesn’t use lcd filter by default :upside_down_face:

9 Likes

Unfortunately, it didn’t work.

Wait, I was looking at the images that I had posted! It did work! My fonts are normal now!
Thanks!

4 Likes

Such a classics! :rofl:

5 Likes

Thanks for the topic and the solution!
I did not even realize I had this problem until I read the topic … Fonts just looked different. But they look definitely better now xD

3 Likes

It’s not only Firefox though, but any program using fontconfig…

Here’s where it all started :upside_down_face:

2 Likes

So it depends on the choice of D.E.?

from what I understand, it depends on if you enable subpixel rendering in your DE settings. If you activate that (or if it is active by default), you should also activate the lcdfilter. Of course on a DE that does not offer subpixel rendering, you won’t see that font behaviour anyway.

Nah it depends on nothing except fontconfig settings, which is DE agnostic…
Except if you completely turn off subpixel rendering, which is a bad idea anyway.

Not many newcomers know of it’s existence, i didn’t since some time ago when i couldn’t tell why KDE fonts doesn’t change some programs fonts settings :laughing:

You can learn more:

2 Likes

Thanks for including us into ‘le club’ lol
For a short while there, I didin’t know If I was losing my mind or my eyesight, with the full lockdown we have here. I had to tell my dog all about it, still not sure which of the 2 he thinks is happening :wink:

3 Likes

I don’t see any font problem on Firefox? I am using default dejavu serif 16

Screenshot_20201110_234831

on old installations, the 11-lcdfilter-default.conf should still be active by default.
The problem should only be visible on new installations that were installed after the fontconfig defaults changed.
At least on a EnOS VM that I installed some time ago, the 11-lcdfilter-default.conf is still active after updating, while on my fresh installation from the weekend, the issue was visible and 11-lcdfilter-default.conf was disabled there.

For me there was switch from update on older installation

The letters in the screenshot don’t look good. For example the word “Fonts” in the titlebar: the “o” is squished on the left side and the stems of the “n” have a different width.

I looks fine to me i’m not seeing it on my system. It looks normal. :man_shrugging:

I thought that too, but after activating the lcdfilter and restarting firefox I could clearly see the difference.