Fingerprint suddenly stopped working

Hi there,

Yesterday I played around with Ubuntu in a KVM. I passed through the fingerprint device to see hoe it does with Ubuntu.

Later in the evening - the vm was stopped and vm Manager terminated - my fingers weren’t detected anymore.

I tried to readd them by deleting the current ones (worked) but adding a new finger fails with an unknown error. Fprintd service is up, only that generic error is thrown with both gui and cli.

Even removing the pass through in the (not running) vm didnt help

Any ideas how to get more logs?

HW must be okay as it works in vm and for unlocking BIOS.


After following hundreds of threads even deleting fingers from all VMs and even from BIOS didn’t help.

In the end removing the
directory did the trick.

It got recreated when enrolling new fingers.

EDIT: and some more assumptions…

Registering the same finger in the Ubuntu VM seems to have stored this information in the sensor as well. After that the sensor information didn’t match the reference in my Endeavour Host /var/lib/fprint

This lead to my finger not being recognized anymore from Endeavour. I guess deleting the directory and re-registering would have been enough, but some weir error messages mislead me to do unneccessary things.

The errors (so google wil find them here)

with wrong finger-data in /var/lib/fprint
❯ fprintd-enroll
Using device /net/reactivated/Fprint/Device/0
Enrolling right-index-finger finger.
Enroll result: enroll-stage-passed
Enroll result: enroll-unknown-error

after deleting all fingers from sensor and bios I got:
❯ fprintd-enroll
Using device /net/reactivated/Fprint/Device/0
Enrolling right-index-finger finger.

relevant line from log via journalctl --unit fprint.service -f after service restart and fprintd-enroll:
Device reported an error during identify for enroll: Unexpected result from device 502


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.