File manager - limited access

This makes me feel like a newbie again - so here goes. When I attempt to access certain directories, ones marked with an X on their corner, I am barred from entering them - even for looking. This behaviour is consistent across EndeavourOS installs. I have no idea what the setting is, nor where it is found - but I definitely don’t see this in my vanilla Arch build, or elsewhere for that matter.

What is the setting (and where) - and why? Should I disable the setting here, or enable it on my other Arch-base builds? It doesn’t stop me from doing what I need to do - but it certainly slows me down :smile:

Example directories? I can get into /boot (which is a root owned dir) but not into /boot/efi (and beyond).
Is it just a recursive chmod away from change?

Freebird54

I get that in Thunar and you need to open thunar as root with sudo thunar in the terminal and then you don’t get the x on certain folders. That’s what i see anyway.

True enough - and that’s why I have those settings in thunar to allow me open a ‘sudo thunar’ in the directory I am visiting. For that matter, I can edit as root directly from thunar as well. I strongly suspect that a chmod setting has produced that effect, however - and presumably it could be reversed. I am not a fan of octal numbers though, as I am sadly out of practice! I expect (and am pleased) that I can’t DO anything in a root directory without opening a ‘root thunar’, but it is simpler to at least SEE in there without the hassle!

I guess I’ll just have to look up the permission patterns that produce those results, and how to override them! IT certainly was a surprise to run into them, when they aren’t on any other distro’s that I am familiar with (including Arch).

Freebird54

It is all about permissions, and how you have mounted the folders.
Terminal command

ls -l ”folderpath”

will show the permissions.
And /etc/fstab shows permanent mounts and parameters.

Comparison of /etc/fstab between your installed systems may show the difference.

Commands chmod, chown and chgrp are your friends! And the man command.

Yeah, I suspected that! I was hoping for more helpful friends than man chgrp though! (after all, laziness increases with age, I’m told. Hope that’s why!).

OK - I’ll dig in and fix it myself :smile:

Freebird54

Btw chmod command can use more than octal numbers… e.g.

   chmod g+rx,o-rwx somefileorfolder

That adds read and execute rights to group, and removes all rights from other users.

Yup - just re-reading on that. I seldom do anything other than chmod +x or chmod +s on a single file though. Just because I’ve been at this since the 90’s doesn’t mean I remember anything!

I was just hoping to figure out what had been done in setup - reversing it is my problem anyway, though!

Been near your main machine yet? (for looking at wiki2.tar.gz)

Freebird54

Been sleeping only… :wink:

What a good idea! I should try that sometime too :grin:

FB

1 Like

Forgot to ask - what’s your UTC offset :grin: I’m at -4 if you couldn’t guess…

FB

+2

Almost 08:40 then - no wonder you were sleeping! Anyway, I guess I’m off to make those dirs match what they are on Arch - I’m spending too much time in /boot/efi/EFI to have it any other way…

1 Like

To me the binary representation is helpful in remembering the numeric method in setting the permissions :slightly_smiling_face:
Considering each set of permissions (rwx) you can view it as a 3-bit binary number. For example, 001 (1) will translate to --x, 010 (2) to -w- and 100 (4) to r–. All permissions granted will look like 111 (7). So, in order to use the octal values you just need to basically convert the binary value of each set into decimal (octal) and write it on order of user, group and others. For example to give to the user and the user’s group (r )ead and (w)rite permissions and (r )ead permissions to others it would look like 110 (6) 110 (6) 100 (4) – so chmod 664 :smiley:

3 Likes

I guess I should have written “I’m not a fan of having to think that hard to get something done” - as it would have been somewhat truer! An excellent explanation, that has earned being saved in the “Useful” directory for reference purposes! (alongside such gems as “aliases” and “Dirsetup” and “blkid”)

It is more a matter of so seldom having to deal with it, than of conceptual difficulties - but I have to go through the conceptual barrier everytime I need it! Again - thanks for the clarity - with a little practice I will undoubtedly be able to set things up to match the balance of security with access that I prefer.

Freebird54

1 Like

If you’re referring to my message above, I apologize, I just wasn’t able to express myself clearly (as it’s often the case :sweat: ). What I meant, is that basically each permission is a flag, set by the corresponding bit, and this is where those mysterious octals originate from. At least I think that this is the case, not sure whether it’s really represented like that. But it helps anyways and is more convenient to type than the other method (more human readable).
Good luck with setting things up :slightly_smiling_face:

Nope - I was referring to a condition I seem to have developed along with grey hair! Your explanation was perfect for the circumstances - I suspected (or faintly remembered?) that it was something like that, but the details had escaped me (if they were ever in hand).

8 bit flags are something I am all too familiar with (AND OR XOR) going back to C64 assembly days - the 54 in my name refers to a year :smile:

So - actually - thanks for the explanation, as I said I kept it for reference. It’ll likely be ‘hovering’ over my terminal as I try to ‘fix’ the problem…

Freebird54

1 Like

@freebird54
Some offtopic - have you already looked at your wiki article here? Forgot to say: I added your Case Study as a link to the end of your wiki article. Could you please check it?

1 Like

Wondered if that would be its best use. Any changes needed to do that? I’ll go look at it now…

Freebird54

I converted the html doc to markdown with pandoc. There were some conversion typos but I fixed them. Hope it is what you meant it to be! :wink:

Nope - it came through fine. Hopefully it can help someone at some point…

Freebird54

2 Likes