Falla al intentar actualizar gst-plugins-ugly

Creo que el título lo dice todo y la imagen lo explica, hay un argumento erróneo o nulo.
image

Could you run:
‘LANG=C sudo pacman -Syu’ and show the output (will be English then)

image
Ya habia desinstalado el programa para que no estorbara en las actualizaciones.
Saludos
I had already uninstalled the program so it wouldn’t get in the way of the updates.
Greetings

Podría intentar borrar el caché de pacman:
’ sudo pacman -Scc’

el paquete se acaba de distribuir, por lo que puede haber una diferencia entre la base de datos local de pacman y el paquete disponible en el servidor.
entonces también puede ayudar a actualizar la lista espejo.
Nuestra aplicación de “welcome” puede hacer eso

traductor de internet era mi amigo;)
muestra tu lista de espejos:
cat /etc/pacman.d/mirrorlist | curl -F 'f:1=<-' ix.io

image
http://ix.io/27NG
Asi?

update your mirrorlist!
and renew database ‘sudo pacman -Syy’ before try installing again.

Don’t work
image

what is the output of : ls /var/cache/pacman/pkg/*.part

¿Podría mostrar también la salida del comando

    pacman -Qs gst

strange:

pacman -Qs gst
local/gst-libav 1.16.2-1
    GStreamer open-source multimedia framework FFmpeg plugin
local/gst-plugins-bad 1.16.2-1
    GStreamer open-source multimedia framework bad plugins
local/gst-plugins-base 1.16.2-1
    GStreamer open-source multimedia framework base plugins
local/gst-plugins-base-libs 1.16.2-1
    GStreamer open-source multimedia framework base libraries
local/gst-plugins-good 1.16.2-1
    GStreamer open-source multimedia framework good plugins
local/gst-plugins-ugly 1.16.2-2
    GStreamer open-source multimedia framework ugly plugins
local/gstreamer 1.16.2-1
    GStreamer open-source multimedia framework core library

ugly = 2-2 Last Updated: 2020-01-13 10:17 UTC

mayby you have to look in the /var/cache/pacman/pkg mayby some *.part files makes these error on one part have to identify first ?

i never have had this error…
to see if it is an remote issue or something locally try downloading the package and install locally:

wget http://mirrors.evowise.com/archlinux/extra/os/x86_64/gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz
 sudo pacman -U gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz

[aldo@aldp-lap ~]$ ls /var/cache/pacman/pkg/*.part
/var/cache/pacman/pkg/gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz.part
[aldo@aldp-lap ~]$

2 Likes

Thank you all very much, I deleted the .part file and everything worked fine.
sudo rm /var/cache/pacman/pkg/gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz.part

[aldo@aldp-lap ~]$  ls /var/cache/pacman/pkg/*.part
/var/cache/pacman/pkg/gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz.part
[aldo@aldp-lap ~]$ sudo rm /var/cache/pacman/pkg/gst-plugins-ugly-1.16.2-2-x86_64.pkg.tar.xz.part
[sudo] password for aldo: 
[aldo@aldp-lap ~]$  ls /var/cache/pacman/pkg/*.part
ls: no se puede acceder a '/var/cache/pacman/pkg/*.part': No existe el fichero o el directorio
[aldo@aldp-lap ~]$ LANG=C sudo pacman -S gst-plugins-ugly
resolving dependencies...
looking for conflicting packages...

Packages (1) gst-plugins-ugly-1.16.2-2

Total Download Size:   0,19 MiB
Total Installed Size:  0,65 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 gst-plugins-ugly...   189,7 KiB   903 KiB/s 00:00 [----------------------] 100%
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
(1/1) loading package files                        [----------------------] 100%
(1/1) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/1) installing gst-plugins-ugly                  [----------------------] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[aldo@aldp-lap ~]$ yay -Syu
:: Sincronizando las bases de datos de los paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
 multilib está actualizado
 endeavouros está actualizado
:: Iniciando actualización completa del sistema...
...el sistema ya está actualizado.
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Missing AUR Packages:  python-sip-pyqt5
 there is nothing to do
´´´
many thanks to everyone
2 Likes