Failure to boot after update

The computer got stuck in between updating the kernels for 3 hours. I force quit and on reboot it shows:
error file ‘/boot/vmlinuz-linux’ not found
error: you need to load the kernel first

Can someone please help me?

That is bad. In the future if you have to kill the update process you can but you need to finish the update before you reboot.

Boot off a live ISO, use arch-chroot to access your install and update your system.

1 Like

Thanks. I tried to research the problem before and came to a similar solution, but I’m not sure what to chroot to? Looked at the Arch wiki, it’s not helping me. I’m on the live USB right now.

Take a look at this and let us know if you have questions.

That’s where I’ve been looking at. For example I know that this is the structure and sda3 is my install.

loop0    7:0    0   1.7G  1 loop /run/archiso/sfs/airootfs
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0 245.2G  0 part 
├─sda2   8:2    0     2G  0 part 
├─sda3   8:3    0  78.8G  0 part 
└─sda4   8:4    0     1K  0 part 
sdb      8:16   1  14.4G  0 disk /run/archiso/bootmnt
├─sdb1   8:17   1   1.8G  0 part 
└─sdb2   8:18   1    64M  0 part 
sr0     11:0    1 600.7M  0 rom  

But I keep hitting errors when trying to chroot. I must be doing something wrong.

Can we see the output of:

1 Like
NAME     SIZE TYPE MOUNTPOINT              UUID                                 FSTYPE   LABEL
loop0    1.7G loop /run/archiso/sfs/airoot                                      squashfs 
sda    465.8G disk                                                                       
├─sda1 245.2G part                         93a7d153-cb36-4e39-85c2-d8846be2f47a ext4     rootMX19
├─sda2     2G part                         691e1015-446c-4b11-8db3-959e5850af6a swap     
├─sda3  78.8G part                         12293d57-22e8-4e10-a877-9129afd67204 ext4     
└─sda4     1K part                                                                       
sdb     14.4G disk /run/archiso/bootmnt    2020-09-20-20-31-31-00               iso9660  ENDEAVOUROS
├─sdb1   1.8G part                         2020-09-20-20-31-31-00               iso9660  ENDEAVOUROS
└─sdb2    64M part                         8D52-3AEA                            vfat     ARCHISO_EFI
sr0    600.7M rom                           

Try this:

sudo mount /dev/sda3 /mnt
sudo arch-choot /mnt

That should give you a # prompt

From there you can type:

pacman -Syu

Thanks, so far so good. However I get this even though I have intrnet access:
:: Synchronizing package databases…
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to update endeavouros (unable to lock database)
error: failed to synchronize all databases

rm /var/lib/pacman/db.lck

Ok, it seems to be updating. Crossing my fingers!

1 Like

Bad luck, same error. I’ll redo everything one more time. The update was way too fast which I thought it was strange.

Now that is weird.
[root@archiso /]# pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
endeavouros is up to date
:: Starting full system upgrade…
there is nothing to do
[root@archiso /]#

Try pacman -Syyuu

same, there is nothing to do


sudo pacman -S linux linux-headers
sudo mkinitcpio -P

ok, it’s building something now.

It sounds like the kernel has already finished updating.

What @xircon gave you above will most likely resolve the issue in addition to updating.

Running mkinitcpio is probably not needed there but it won’t hurt, the initrams will just be generated twice.


Thank you all, it’s solved!!


I want to add that I really appreciate the speed and info you guys gave me to solve this, as well as your patience.
This is what makes the difference in this forum compared to others.
A big Thank you again!