Fails at bootloader. Can't find device

I wanted to start a new with a pure endeavour install rather than my frankenendeavtergos. Well It fails at the end of the install at the install bootloader portion. The error I get says can’t find device for /boot/grub. I am using existing partitions. There is an existing windows install. I used the esp as /boot/efi with the flags boot and esp. I should note yesterday I was able to install by mounting it to /boot instead, but, then grub couldn’t find windows and the efi folder was locked.

Here is my log.

Did you disabled “fast boot” in windows? It look like you have too many disks. Did you selected the correct device in “Calamares” installer?
You can use the 99MB windows boot partition for installing endeavour os alongside with windows. Just need to change the flags to boot and esp. No need to create a separate 512MB F32 efi entry.

Boot in to windows and delete any existing old boot entries. Command Prompt, type bcdedit /enum firmware Check for boot entries of any old installations and delete them by typing bcdedit /delete {identifier} (CNTRL+C to copy the boot identifier ID)
PS: DON’T mess with windows boot entry in there.
Do a complete shut down by typing “shutdown /s /f /t 0” , disable “fast boot” and then try to install endeavour again.
Good luck!

Fast boot and secure boot both off. I set the flags with gparted.
I am reusing my old set up. LVM2 /,/home, ,and, /data also a swap. I already deleted the existing boot entries. Calamares will not format / or swap.

can’t do it with gparted because they are lvm. I activated the volume group chrooted and did grub-install and mkconfig. It boots me into the non efi system I installed yesterday because calamares won’t format.

Although, grub shows endeavour and windows. it boots into both. I suppose I don’t really need to do anything.

It is in UEFI. As I said in the TG group. You didn’t recreate the partition table, said you have it in GPT, hence calamares or any other basic installer won’t even let you go past any partitioning menu, unless you’ve selected partitons, that are created on an mbr disk. So it can’t boot in MBR mode, neither was it installed in MBR mode.

Looking at the log, I doubt it might be an issue with calamares. There was no mishaps on partition selection or anything for that matter.

22:21:26 [6]: [PYTHON JOB]:  "Bootloader: grub (efi)" 
22:21:26 [6]: Running "chroot" ("/tmp/calamares-root-7jjdwckl", "grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=EndeavourOS", "--force") 
22:21:27 [6]: Finished. Exit code: 1 
22:21:27 [6]: Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=EndeavourOS", "--force") 
22:21:27 [6]: Target output:
Installing for x86_64-efi platform.
grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).

What is your partition scheme?
Can you show here the output of commands:

lsblk -fm
sudo fdisk -l

I tried many, many times but calamares installer always seemed to fail when I had an lvm partioning scheme. It always failed as you are seeing. Without lvm I didn’t have any problems on another box. So I ended up doing a normal arch install with lvm, gpt and didn’t have any problems.

Hello @woodrowwsmith
Have you been able to get that power house installed again? I still haven’t gotten my AMD 3800X set up yet but March break is coming. I’m not big on lvm as i don’t know much about setting it up and not having a requirement for it.

At this point I have a working EndeavourOS install. The only problem is root has no access to /boot/efi. Grub-mkconfig works and both OSes are recognized and have a boot entry in grub, so I’m not sweating it. And yes I reused my LVM partitions.

You might want to try a little trick that i have used for the EFI partition and grub. If you go to major geeks and down load easy uefi free and install that on Windows. What it does is allow you to see the EFI partitions and edit them and also move the placement of the boot order because you may find that it’s there but it may have multiple instances and just moving the order will fix it. You should have grub as the first entry for boot and it may not be or it has another instance that is the incorrect one. It will allow you to see exactly where the files are and move the boot position. The problem with Uefi is it keeps the entries and sometimes not in the proper order.

Edit: Does your grub have both entries and boots to both or am i misunderstanding?

Grub has entries for both. As I said grub-mkconfig works. There is really nothing to do.

Okay I guess i’m not really understanding the issue as i don’t use LVM . Glad it is working for you anyway.

has nothing to do with LVM. The installation issue was. It is a problem with folder permissions. Thanks anyway.

You don’t have to delete the thread. It’ll be good to keep this around if something similar happens again.