Failed unmounting /home (found why...)

Hi all,
Since I have re-installed EOS with BTRFS all is working perfectly apart a message I get every time at shutdown. It says : [Failed] unmounting /home

Now, it appears for about 1 sec and the shutdown continue. It does not seems to affect the system, next boot is working fine, and I have not visible issue… but the same message appears again at shutdown.

In the journal the message appears like this:

Sep 28 15:14:11 pierre-latitude5500 systemd[1]: Failed unmounting /home.
░░ Subject: A stop job for unit home.mount has finished
░░ Defined-By: systemd
░░ Support:
░░ A stop job for unit home.mount has finished.
░░ The job identifier is 4551 and the job result is failed.
– Boot 8f0cc675afdc453a8df8d1c4b4452e4f –

In case it is needed, here is my fstab

My fstab

UUID=BC10-75F6 /boot/efi vfat umask=0077 0 2
/dev/mapper/luks-5b9dc459-3e79-4f25-ac40-e9cffd47170d / btrfs subvol=/@,defaults,noatime,space_cache,
autodefrag,ssd 0 1
/dev/mapper/luks-5b9dc459-3e79-4f25-ac40-e9cffd47170d /home btrfs subvol=/@home,defaults,noatime,space_ca
che,autodefrag,ssd 0 2
/dev/mapper/luks-5b9dc459-3e79-4f25-ac40-e9cffd47170d /var/cache btrfs subvol=/@cache,defaults,noatime,space_c
ache,autodefrag,ssd 0 2
/dev/mapper/luks-5b9dc459-3e79-4f25-ac40-e9cffd47170d /var/log btrfs subvol=/@log,defaults,noatime,space_cac
he,autodefrag,ssd 0 2

I’ll also add that I run EOS in a LUKS encrypted BTRFS partition. My DE is KDE

Any thought about how to debug / understand / correct / get rid of this message ?
Thanks !

Check that UUIDs match?

I have found the issue :upside_down_face: … I had a Veracrypt volume build as an Ext4 filesystem which I mount since years. It was always unmounted gracefully in the background when I had to shutdown when I was using an Ext4 filesystem for Eos.

Now I run Btrfs and Luks. I don’t know if the issue was caused by Btrfs or Luks (or both), but while I could normally mount the Veracrypt volume and uses it, it was not automatically unmounted at shutdown and caused the failed unmount issue.

So not really a full solution, but as I now run Luks, I don’t really need to use Veracrypt… and I have no more this “Failed unmounting /home” message.