Failed to update: endeavouros: download library error

Trying to install ZSH, using EndeavourOS on VBox, I ran some commands that hosed my download library. I was having an issue trying to make ZSH(shell) my default. I would change it, exit cmdline and re-enter cmdline only to find that it would not take. I found out that you have to exit the VM and restart and everything works! So, that’s a done deal. My main issue(s) now is error setting certificate verify locations and unable to check for updates(could not synchronize databases).

But… zsh is the default already?
And yes I changed to fish (on bare metal) and it appeared it didn’t work until I rebooted.

As for the main question tho I have no answers…

BASH was my default command line environment. I’m trying to install ‘Oh-My-ZSH’ environment.

Huh. Did you install the stable release? Because mine had zsh installed and running.

I installed endeavouros-2019.07.15_x86.iso. I re-installed it, and I’m back to bash, for now.

That’s… weird.

The first and second install made BASH the default env. I changed it to ZSH in the second install, all in a VM. I haven’t hosed the second install just yet and everything is working. I had probs with getting curl to install on the first install, but the second worked without a ‘hick-up!’ This distro is looking very promising.

1 Like

:no_mouth: you just find a major BUG … we configure to make zsh default shell, but it seems due to some changes it do not work on the release version anymore.

It is installed by default:

[joe@joe-pc ~]$ pacman -Q zsh
zsh 5.7.1-1

configs are present, but it runs bash:

[joe@joe-pc ~]$ pacman -Q zsh
zsh 5.7.1-1

but a simple
chsh -s /bin/zsh
logout login from session will bring it back!

sorry for this, i have a look what went wrong now.

To see what was the reason here would need to get the exact terminal output from update.

Odd thing is that it was default for me. I installed at 19:00 on the 15th

with the stable release? or the beta?

I was a little surprised by the choice but it seems a,lot of distros pick zsh nowadays. Even Manjaro Architect has it as first choice for shell.

Anyway yes, I downloaded the stable iso as soon as I got home and it was zsh. At least I assume it was the stable? No mentioning of a beta in description or filename.

endeavouros: download library error

sudo pacman-key --init
sudo pacman-key --populate archlinux endeavouros
sudo pacman-key --refresh-keys
sudo pacman -Syy

I had the same issues with a fresh install. I had to repopulate the key database as you outlined.