Failed to execute /init (error -2) After update

bootctl install
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/efi/EFI/systemd/systemd-bootx64.efi".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/efi/EFI/BOOT/BOOTX64.EFI".
⚠️ Mount point '/efi' which backs the random seed file is world accessible, which is a security hole! ⚠️
⚠️ Random seed file '/efi/loader/random-seed' is world accessible, which is a security hole! ⚠️
Random seed file /efi/loader/random-seed successfully refreshed (32 bytes).
Created EFI boot entry "Linux Boot Manager".

the /efi/loader/entries folder is empty

deleted and recreated the efi partition (with gparted, FAT32 format, flag efi,boot)
mounted the partition in /mnt/efi
reinstalled the kernel (pacman -S linux)
installed systemd-boot (bootctl install)

entries are created, but at boot always the same error "Failed to execute /init (error -2)

It is probably not a bootloader issue.

It is getting far enough that I would suspect there is something wrong with your initrd.

However, rebuilding those doesn’t help. Often an error in the initrd is actually caused by an error on the system itself since the initrd is build by compressing certain files from the system into the initrd.

So, ultimately, all that logic leads us to…something is probably wrong with the system. Which is, of course, terribly unhelpful.

It is possible that whatever is causing this problem was introduced before the update but the update triggered rebuilding the initrds and, as a result, pulled in whatever the problem is/was.

Have you tried booting off the fallback entry? If that doesn’t work can you share the output of:

lsinitrd /efi/ae6b8b05ea3342b7b78a9c3153c943a5/6.6.1-arch1-1/initrd

I found some errors in fstab, corrected them but nothing changed.

this the output of lsinitrd
lsinitrd.odt (106.5 KB)

Boot kernel-lts-fallback without amd_iommu=on iommu=pt video=efifb:off

What did you change specifically?

Please use a pastebin service if the data is too large for the forum.

the mount point was set to /boot (I don’t know why?) and there were some disk write options that were not needed

the output sorry

That is probably the problem. You need to run dracut-rebuild from the chroot after making that change.

I tried “dracut-rebuild”, same error at boot