Failed to commit transaction, but nothing helped so far

Hello there

I’ trying just to update with pacman -Syu, but it shows me this.

error: failed to commit transaction (conflicting files)
openssl: /usr/lib/libcrypto.so.3 exists in filesystem (owned by openssl-3.0)
openssl: /usr/lib/libssl.so.3 exists in filesystem (owned by openssl-3.0)
Errors occurred, no packages were upgraded.
Done - Press enter to exit

I tried every command I know and went to forums to help, but none of the solutions helped me.
If there is someone how knows why this is showing to me and know why I can’t update my system and is willing to help me, I will be really thankful.

Can you remove openssl-3.0 before updating?

What does pacman -Q | grep ssl return?

1 Like

It shows me this:

openssl 1.1.1.q-1
openssl-3.0 3.0.6-1

Thank you dalto for replying so fast!

Does sudo pacman -R openssl-3.0 cause any problems?

2 Likes

Never mind, I can not believe that just removing openssl just worked!
I mean I feel really dumb right now… and did not even needed openssl apart from one school exercise.
Thank you very much dalto. Btw I’ve seen you in the other posts and couldn’t believe you wrote to me hahaha.
You’re doing gods work!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.