Failed pacman -Syu bonked everything

Hi, so basically today I decided to run pacman -Syu, it said that wasn’t succesfull and I noticed that some app weren’t working so I restarted my pc and when i tried to login in my EndeavourOS partition it gave me an error saying vmlinuz-linux not found , error: you need to load the kernel first so I used a live usb and tried fixing the problem thinking it was a grub problem, but now when I turn on my pc the linux partition doesn’t show up and i can’t boot it, I can only boot in windows. How can i fix that? Thanks in advance.

1 Like

Boot up your live usb and post the output of the following commands for us to have some initial ideas about your system:

sudo parted -l
efibootmgr

Copy the teminal outpur as text, paste it into your reply and press Ctrl-E to format. No screenshots please.

Hey, still me just from another account because I’m dumb and forgot my credentials, btw those are the outputs:

sudo parted -l
Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sda: 124GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      2595MB  2760MB  165MB  primary  fat16        esp


Model: KBG50ZNV512G KIOXIA (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB  16.8MB               Microsoft reserved partition  msftres
 3      290MB   361GB  361GB                Basic data partition          msftdata
 4      361GB   511GB  150GB   ext4         endeavouros
 5      511GB   512GB  645MB   ntfs         Basic data partition          hidden, diag, no_automount
efibootmgr
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0000,0001,0002,0003
Boot0000* endeavouros   HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)/File(\EFI\endeavouros\grubx64.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0002* Internal Hard Disk    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,8C-E3-8E-04-03-F5-05-41)/HD(1,GPT,d663b595-7515-4711-bfd7-33c99ac3f85c,0x800,0x82000)0000424f
Boot0003* USB Drive (UEFI) - KingstonDataTraveler 3.0PMAP       PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(5,0)/CDROM(1,0x4d5940,0x4ea98)0000424f
Boot0004* USB Drive (UEFI) - KingstonDataTraveler 3.0PMAP       PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(5,0)/HD(2,MBR,0x4e4305b5,0x4d5940,0x4e800)0000424f
1 Like

We can try recovering your system.

Depending on how broken your system is, it may be an easy task or a difficult and tedious one.

OBS! In the following, if you will be getting any error messages at any step, please don’t go any further and post them here first.

Let’s get chrooted into your system first.

In the live session, make sure you have network connection.

Open a terminal and run:

sudo mount /dev/nvme0n1p4 /mnt
sudo mount /dev/nvme0n1p1 /mnt/boot/efi
sudo arch-chroot /mnt

Now, in chroot, try updating your system:

pacman -Syyu

Reinstall the bootloader’s binary:

grub-install --bootloader-id=endeavouros

Regenerate the grub.cfg:

grub-mkconfig -o /boot/grub/grub.cfg

If everything is fine so far, type exit followed by enter to quir chroot.

Reboot.

Edit: correction of the command lines

I already got an error at the second step:


sudo mount /dev/nvme0n1p1 /mn/boot/efi
mount: /mn/boot/efi: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
1 Like

I am sorry, that was a mistake on my part.

There is a missing t there. The correct line:

sudo mount /dev/nvme0n1p1 /mnt/boot/efi
1 Like
sudo arch-chroot
==> ERROR: No chroot directory specified

I think I am going to need some sleep or much more coffee than I have already had:

sudo arch-chroot /mnt

My apologies @mejixib573 !

1 Like

Dw for the small mistakes, luckily it worked, thanks :grin:

Sounds great! Glad to know it worked out!

Also, welcome to EnOS’ community @mejixib573!

By the the number 572, 573, does it have to do with the number of accounts you have forgotten the credentials for? :wink: :rofl:

PS. Off for taking a nap :sweat_smile: