Failed dual boot installation

I was trying to install endeavor alongside ubuntu but installation failed as it ‘could not add partition to device dev/sda’

This is the partitioning i did before installing

First let me know how to fix this, then, if you have the time, explain in detail what i did wrong

It seems you have a MBR/UEFI install which is not common (actually this is the first time I am seeing such a setup made by someone else) . This might be confusing the installer.
Make sure you are booted in UEFI mode, manually partition the drive and try again.

looks a bit strange indeed… but seems ubuntu is running on uefi mode…
First is to make sure you boot installer ISO without any modifications some USB writing tools doing…
And second is to check if ISo is booted in UEFI mode:
in a terminal run:

sudo efibootmgr

that should show something like so:
on uefi mode … if not uefi mode it say no:

1 Like

yea, i booted my usb using legacy boot, is that the problem?

what does that even mean? I’m just started learning computers in depth 3 months ago. I’m qualified to understand the jargon

What you appear to have ended up with is an MBR partitioning scheme instead of GPT. Perhaps if you set up the partitions first (GPT), then use manual mode to select them for the install…

Of course, it might be enough to ensure you boot the ISO in UEFI mode - but I am not sure what’s where at the moment :grin:

BTW - this is not a normal outcome - so we’re not sure what you did!

1 Like

As said above, you have a MBR partitioning scheme and have installed your Ubuntu in, what seems to be, UEFI mode.

In Ubuntu, what does

test -d /sys/firmware/efi && echo UEFI || echo BIOS

say? Just to make sure about the install mode.


thats what it says

For a BIOS mode install, you didn’t have to make an ESP (EFI System Partition) since the bootloader should be installed in the MBR of the disk and not onto a particular partition.

I guess, in order to install EnOS, you could boot your USB in Legacy mode, in the installer choose manuel installation and point it to the partition where you want it to be installed. Choose the MBR of the disk (/dev/sda) as the location for installation of the bootloader.

1 Like

Is the computer UEFI? If it is then you should install it all in UEFI mode. Secure boot should be disabled, CSM mode turned off. No legacy UEFI only. Boot in UEFI mode not legacy. Install in UEFI mode. Don’t use legacy mode to boot the usb if your system is UEFI. If your computer does not have UEFI then install in MBR is obvious.

Welcome to the “I watched a tutorial in the internets” zone! :stuck_out_tongue_winking_eye:

Most probably, OP just followed a tutorial for UEFI, but missed the part of making sure to boot in UEFI as well. :man_shrugging: I’ve seen it lots of times :cry:

Ubuntu is in Legacy, as confirmed, but includes a useless /boot/efi mount.

1 Like

how can i be sure my laptop is UEFI?

see this

Run command

efivar --list

It should display lots of lines if it is UEFI.

efivar: error listing variables: Function not implemented

btw my laptop boots in both UEFI and Legacy and i recently updated the BIOS. So, with that info, can I say that it is in UEFI?

so my laptop is in UEFI mode and installing Endeavour by booting in UEFI should solve the problem?

No, use Legacy mode.

Why do you think your your laptop is booting in UEFI mode? The above command shows it’s not!

If you run the this command also as pointed out by @joekamprad it will show you if EFI variables are supported. If it say’s they aren’t supported then it’s not UEFI!

sudo efibootmgr

Edit: If it is UEFI then you have it set to be legacy only! It has to be set to UEFI with secure boot disabled, CSM turned off, UEFI mode only. Otherwise it wont even have these settings in the Bios.

Edit2: What is your hardware? You can post a link for this command.

inxi -Faz | eos-sendlog

The OP has already installed Ubuntu in Bios/Legacy mode :wink:
So for a dualboot to work properly, that is, for the grub to be able to add boot entries for both systems to the boot menu, the second system also needs to be installed in the same mode.