Failed dependencies and meson reconfigure

Hey. I’ve been trying to install fragments to EndeavourOS. In trying to get dependencies, I managed to sorta make it work with -sri. I cloned the git repo for fragments, then ran makepkg -sri. I got this: ''error: failed to run custom build command for libadwaita-sys v0.6.0. Then, I downloaded that git repo and ran it. That seemed to finish, I can’t really tell cause the output is ridiculously long, but i didn’t see any errors at the bottom. I tried this again after that: fragments-git]$ makepkg -sri, that errored out again, with this:
agments build
Directory already configured.

Just run your build command (e.g. ninja) and Meson will regenerate as necessary.
Run "meson setup --reconfigure to force Meson to regenerate.

If build failures persist, run “meson setup --wipe” to rebuild from scratch
using the same options as passed when configuring the build.

I’ve been trying to figure out what directory meson setup --wipe needs cause it tells me it needs a directory.
[rafael@endevour-claw fragments-git]$ meson setup --reconfigure

ERROR: Must specify at least one directory name.

Does anybody know what this is about?

Welcome! :smile:

The PKGBUILD of fragments is in the AUR, have you tried installing fragments with yay?

yay -S fragments

Fragments is available in the extra repo as well.


extra/fragments 2.1.1-1 [installed]
    BitTorrent client for GNOME

pacman -S fragments
1 Like

Thanks! My bad, read my yay list too hastily. Fixed this into the post above.

It’s part of the Gnome installation, so was wondering why anyone would want to manually compile it or to install it from the AUR. Maybe OP has a specific reason for it?

Yeah, might be a reason for it. But if not, then the official version is what I’d recommend too.

I don’t see it in the OS when I look for it, so I went online to look for instructions on how to install it.

How do I know when some package is in the extra repo? The docs I read did not mention where to look for stuff before selecting how to install.

Just search for a keyword using pacman or yay.

% pacman -Ss fragments
extra/avogadro-fragments 1.99.0-1
Molecular fragments and inorganic ligands for rapidly building structures
extra/avogadro-molecules 1.99.0-1
Common molecule fragments for visualization in Avogadro
extra/fragments 2.1.1-1 [installed]
BitTorrent client for GNOME
extra/python-sphinxcontrib-towncrier 0.4.0a0-1
An RST directive for injecting a Towncrier-generated changelog draft containing fragments for the unreleased (next) project version
extra/tangler 0.2.0-1
Extracts (tangles) code fragments from Markdown documents
extra/texlive-latexextra 2023.66594-20 (texlive)
TeX Live - LaTeX additional packages

1 Like

Then install it.

% pacman -Syu fragments

1 Like

Fragments?

$ pacman -Sg gnome | grep fragments 
$ pacman -Sg gnome-extra | grep fragments 
$ eos-packagelist GNOME-Desktop | grep fragments

These come up all empty.

Furthermore, it is not part of the GNOME Core apps but Circle apps.

I know, I am nit-picker … :sweat_smile:

2 Likes

lol you are right then, I didn’t bother to check but I have it installed.

local/fragments 2.1.1-1
    BitTorrent client for GNOME

Just because Gnome was in the name made be assume it was either in gnome or gnome-extras. Now that you mention it I do remember installing it separately. Thanks for slapping me on the wrist. :rofl: :wink:

1 Like

I was a nit-picker. Now I am a wrist-slapper too, thanks :rofl:

2 Likes

I didn’t know what other word to use, wrist slapper was meant to be a synonym(word play) for person that corrected me :rofl:

1 Like

Thanks for the help! It seems most everything can be found with pacman. The meson thing was strange but good thing did not have to pursue down that road of fixing it.