Extremely laggy when display is set to 120hz

I just installed EndeavourOS to my laptop. On the live iso it was already incredibly laggy, but I installed anyways thinking that nvidia drivers are going to fix it. I installed nvidia drivers using nvidia-inst, which worked, but did not fix the issue. I then went into my display settings and noticed changing the display refresh rate to 60hz fixes the problem. But since I have a 120hz display, doing that is not satisfactory.
This happens of xfce, but I also tried awesomeWM, which had the same problem.

A video exhibiting this behaviour: https://streamable.com/fyt6km (quality is not great, sorry. Try focusing on the mouse cursor to see it. btop running to show resource usage)

Hardware info: https://0x0.st/Hrsw.txt

Thank you for your time!

Did you start Live ISO with the OpenSource drivers entry, or with Nvidia proprietary?

Check if the issue still happens with the compositor disabled. Maybe some compositor setting could help (using picom maybe?).

You have nvidia with Intel 12th gen so i just wondered if you set 1ibt=off1 as a kernel parameter? Not sure if you are also using grub or systemd boot?

Edit: Sorry i see you have it in the grub command line.

I see it rendering on the Intel. Do you have xf86-video-intel driver installed? You may want to try without it.

Thank you for the suggestion. I’ve tried both, and they both have the same behaviour. Although starting it with the nvidia option gives me a lot of console spam during startup. So maybe that is a sign? How can I log the boot messages?
Disabling compositing doesn’t change anything.

I did have it installed. I removed it using pacman -Rs xf86-video-intel, however nothing changed (apart from the desktop wallpaper weirdly, it’s an xfce one instead of an eos one now)

1 Like

Some logs may help get more info.
Send Xorg and journal logs with eos-sendlog.
I think there is an EOS GUI tool for that, if you prefer a graphical app.

Accidentally left the pacman logs in, ignore those.
Interestingly, the Xorg log is empty, is that normal?
This is from the live boot with nvidia option selected btw.

No. We need from the installed system, if possible. :person_shrugging:

Oh, I’m very sorry, I misunderstood
0x0.st/Hrzt.txt are the Xorg logs
0x0.st/Hrz3.txt is the journalctl

I can’t see any relevant errors in the logs. Had you got them after trying to change frequency, or not?

Post xrandr output as well.

You might want to try linux-lts kernel, if you have it installed, or install it to see.

sudo pacman -Syu linux-lts linux-lts-headers

Reboot and select linux-lts from the boot menu.

Have you ever used any other Linux distro on this system and had better performance?

If your hardware/PC has an option to use one GPU only, you might want to test if the same happens with only Intel, or only Nvidia.

I have no better ideas. Sorry… :person_shrugging:

Damn, I am probably being an idiot here. But I installed linux-lts + headers but they dont show up in the boot menu. So I removed the original kernel, and now it wont boot since I cant find a kernel :joy:
Anyways, I have gotten Linux Mint to work fine on this. However, this hardware is definitely not very compatible with linux, as I’ve had problems with quite a few distros

Ingenious move!! :rofl:
Nevertheless, you can re-install it with pacman, using Live ISO, (without chroot), with --root <mount/point>.

Well, you were right, the LTS kernel works just fine! Pretty weird, but I guess that’s cool. Thank you very much for your help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.