External monitor not detected

Hi fellow :enos: experts. I am trying to connect a
an external monitor from the laptop which has an HDMI port. I have this DisplayPort to HDMI adapter. The monitor is set to autoscan and usually lights up on RGB, but I never tried other ports until now.


Screen 0: minimum 16 x 16, current 1366 x 768, maximum 32767 x 32767
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1366x768      59.80*+

Its Gnome 45 on Wayland, but I have tried x11 with the same result.

inxi -FAZ

  Host: acer Kernel: 6.5.9-arch2-1 arch: x86_64 bits: 64 Desktop: GNOME
    v: 45.1 Distro: EndeavourOS
  Type: Laptop System: Acer product: Aspire ES1-571 v: V1.00
    serial: <superuser required>
  Mobo: Acer model: Aspire ES1-571 v: V1.00 serial: <superuser required>
    UEFI: Insyde v: 1.00 date: 01/04/2016
  Info: dual core model: Intel Core i3-5005U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1898 min/max: 500/1900 cores: 1: 1900 2: 1900 3: 1896
    4: 1896
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Device-2: Realtek Acer 640 × 480 laptop camera driver: uvcvideo type: USB
  Display: wayland server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: gpu: i915 resolution: 1366x768~60Hz
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
    renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel
  API: ALSA v: k6.5.9-arch2-1 status: kernel-api
  Server-1: PipeWire v: 0.3.83 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: 30:65:ec:99:91:e5
  Device-2: Broadcom BCM43142 802.11b/g/n driver: wl
  IF: wlan0 state: dormant mac: da:91:6a:f2:de:37
  Device-1: Lite-On BCM43142A0 driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 465.76 GiB used: 7.51 GiB (1.6%)
  ID-1: /dev/sda vendor: Hitachi model: HTS547550A9E384 size: 465.76 GiB
  ID-1: / size: 456.48 GiB used: 7.51 GiB (1.6%) fs: btrfs dev: /dev/sda3
  ID-2: /boot/efi size: 499 MiB used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1
  ID-3: /home size: 456.48 GiB used: 7.51 GiB (1.6%) fs: btrfs
    dev: /dev/sda3
  ID-4: /var/log size: 456.48 GiB used: 7.51 GiB (1.6%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: partition size: 8.79 GiB used: 0 KiB (0.0%)
    dev: /dev/sda2
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 224 Uptime: 9m Memory: total: 8 GiB available: 7.68 GiB
  used: 2.44 GiB (31.8%) Shell: Bash inxi: 3.3.30

What else can I try?

Is your adapter in the correct direction?

Many of those are not bi-directional. In other words, a DisplayPort to HDMI adapter is different than an HDMI to DisplayPort adapter.



I think that may be the problem, but shouldn’t I still be seeing the physical port output in inxi or xrandr?