External Display Issues On Boot

I am having a hard time trying to figure out the fix for this issue, maybe someone could help me out.

Setup:
Lenovo E490 into a USB C gen 2 dock
DisplayPort to external 32” display

arandr has a monitor.sh saved to utilize only the external display (DP1-2)

This worked fine immediately following my install (fresh) from USB, but rebooting always gives this partial display.

My current work around is to use my keyboard to change the resolution from 2560x1440 to 1920x1440, apply, the switch back and apply. This seems to restore the screen and everything works.

But why is it doing this?

I am going to guess this is i3wm. Have you tried adjusting these settings?:
2021-07-22_07-35
You may have to delete the current monitor.sh and regenerate it after the change.

There is also this note in the .config:

# it could be that you have no primary display set: set one (xrandr --output <output> --primary)

I do have the same View selected 1:8 and I have the DP1-2 set as primary with the built in display not enabled.

That is the default you may need to change it for that monitor. Try 1:16 and 1:4.

I will give both a try to see if this works. Two follow up questions…

  1. What does this setting do?
  2. Could any of this also cause my login screen not to show up on the external display during boot up? I have to always open the lid to log in. When I had Endeavor a while back, I don’t recall having this issue, the display manager is lightdm (I also have xfce installed as a secondary DE). Maybe that is the issue?

You have a lot going on here between adapters external monitors etc. Hard to say. the quoted is very important as you need to comment out dex if you are using a DE alongside i3wm also in the .config:

# dex execute .desktop files
# keep in mind that it can cause issues 
# when second to i3 a DE is installed or mixed usage of i3 + xfce4 or GNOME
# in this cases better disable dex and use manual starting apps using xdg/autostart
exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/

Also commented this line out as well. Reboot coming now.

No change after a reboot. My workaround still works. But its messy lol.
Not sure what else to try here.

it old but i still use on Macbookpro that only run Arch … all instruction there …

hope it help + be useful