Expand root filesystem after shrink

So I wanted to shrink my root file system on my disk so I booted into a live disk environment and used KDE partition manager to shrink the partition but when I rebooted it errors basically saying the filesystem (according to the superblock) is larger than the physical size of the disk and the superblock or partition table is likely corrupt.

So I booted back into the live and tried to expand the disk back but basically the same error occurs when running:
e2fsck -f /dev/nvme0n1p2

How can I re-expand the disk, edit the superblock or fix in some other way?

Or at least mount the drive so I can backup data and reinstall.

I would run testdisk and see if you can reinstate the original partition.

What is the filesystem on the disk and how did you shrink it?

ext4
Used KDE partition manager and just resized it

Wild guess here, but perhaps the uuid has changed and I have no idea how to change it in the boot parameters
Perhaps someone else can be of assistance.