Everything in Firefox on plasma is at ca. 110% magnification

UI elements, webpages, everything is ca. 10% bigger than it should be (similar you hit ctrl + on a webpage). I also can reproduce it in a EOS-VM installation.

Anybody else sees this issue?

I am not seeing it here.

What version of Firefox are you on?

I’m wondering if it could be a scaling issue.

Can you try launching it like this firefox --force-device-scale-factor=1?

Not seeing it over here in :circus_tent: ’

honka_animated-128px-46


Wonder what it is…It can be caused by:

  1. Browser magnification as you’ve mentioned, which is always a bad idea to use since it will break a lot of pages.

  2. Scaling issue, as @LewdLoli mentioned

  3. Fonts problem, like you’re not using defaults in FF or some font is missing and causing it to use other one which shifts line-height enough to make an impression of everything is bigger, are images and stuff like that also bigger?

1 Like

No change, still looks wrong.

Can confirm this is a possibility as well. Had this issue on Brave and it made the UI look really wrong compared to what I had on windows.

Found this while searching for firefox scaling. Maybe something from here would help.
ArchWiki HiDPI - Firefox

Latest from from the official arch repos 106.0.1.

It’s on wayland. I’m trying to reproduce in the VM again at the moment.

Have you checked to see if the same things happens on X or if it Wayland only?

Seems to be related to wayland. Maybe. OK, situation at the moment:

  1. Multimonitor setup with 4k (scaled) and 1080p on Wayland
  2. I created a new desktop user account (incl. new Firefox profile)
  3. Opened this forum in FF, put it on the 1080p monitor in fullscreen and made screenshots:

X11:

X11

Wayland:

wayland

Wayland shows everything (application UI and webpage) at ca. 110% of what is “normal”.

The issue started today.

No issue to repport on GNOME-Wayland.

Firefox looks fine on laptop screen and external monitor (both 1080p).

I also did a fresh online installation of plasma in VirtualBox. Same situation switching between X11 (background) and Wayland (foreground).

Screenshot_20221022_220019

OK, so I usually started Firefox in Wayland mode by setting MOZ_ENABLE_WAYLAND=1 in ~/.pam_environment. But that seems to be ignored at the moment so FF starts in XWayland. Curious.

I set this in /etc/enviroment. :man_shrugging:

What happens if you run

MOZ_ENABLE_WAYLAND=1 firefox
1 Like

I set it ages ago in .pam_environment and forgot about it, but it isn’t picked up anymore. According to the Arch wiki ~/.pam_environment it is deprecated, but I don’t find anything that it shouldn’t work anymore. ~/.pam_environment is gone:

Yes, that works. As soon as MOZ_ENABLE_WAYLAND=1 is present everything is back to normal.

2 Likes

I’ve put this in ~/.config/environment.d/envvars.conf which I saw lately somewhere in the forum.

Edit

Here:

1 Like

Well on the Arch page it says many different things. It’s hard to decipher what the hell they even mean half the time. :man_shrugging: I just put it where i put it and a never had any issues.

The following files can be used for defining global environment variables on your system, each with different limitations:

  • /etc/environment is used by the pam_env module and is shell agnostic so scripting or glob expansion cannot be used. The file only accepts variable=value pairs.

VS. local environment variables, I guess.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.