Ethernet stopped working

Morning guys
I have a problem. Since a day or two my ethernet doesn’t connect me to the internet anymore. I was wondering why the system showed me I was on wifi, so I shut wifi off and was disconnected. I have 3 more PCs plugged into the same router/modem and they all work flawlessly. :expressionless: That’s very weird. Any of you had similar experiences? And what can I do to remedy the situation?

Something wrong with the latest kernel 5.11.6?

Tech: We’re on 20/20 fibre, ONI and router are not even half a meter away from my main machine and all used to work flawlessly. I just wanna connect via ethernet so I don’t need to steal the bandwith speed from hubby who connects wirelessly from another room.

If you were required to install a dkms package for the ethernet to work then, it might help to wait a few days for an update to fix it. Wifi on my pc stopped working with the kernel update, but update fixed it.
Manually compiling the drivers for my wifi, i noticed that the old code refuses to compile against the latest kernel headers.

1 Like

Nothing of that sort unfortunately. It was working and then - without giving any notice - it didn’t work anymore. I’m installing fresh now and ethernet works. At least for now. :expressionless:

1 Like

I had exactly the same issue today.
Wired ethernet suddenly stopped working.
I didn’t do anything, just booted up, Megasync synced and after this the internet was dead.

Only on this desktop, the rest of the laptops are working just fine.
Same problem with the lts and the new kernel.
When I boot Windows which is on another disk/same machine the connection is fine.
Booting up a live ISO, Manjaro or elementary the connection is fine.

What could this be?

Maybe uname -aand hwinfo --network or inxi -nN could give some useful information on what’s going on.

1 Like

Need hardware info

inxi -Na

I don’t think you needed to reinstall for that. But would understand your reasoning because you just want it to work. :wink:

Have you tried to unload r8169? Or to manually start the NetworkManager service?

This is mine:

$ inxi -Na
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Elite Systems driver: r8168 v: 8.049.02-NAPI modules: r8169 
  port: e800 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 

And I have the r8168 installed, I did this some time ago and made it work.
Today it suddenly stopped, without updating or doing anything.

The only way I can make it work is activating my VPN. :upside_down_face:

It looks like it’s running on the kernel module r8169 currently. Not sure about the vpn what it has to do with it. You could try unloading the r8169 kernel module and load the r8168. It was my undertsanding that when the r8168 package is installed that it blacklists the r8169 so it won’t load? You could check that. With an update it may have bumped out the r8168. :man_shrugging:

sudo rmmod r8169
sudo modprobe r8168

Edit: I’m also not positive I’m reading it right either? It could be that it actually is using r8168 but the r8169 is interfering? I would think the module should list as r8168 if it’s using it.

I’ll try to figure it out tomorrow since it’s midnight now.
Weird thing about the VPN, isn’t it?

1 Like

Another thing that I dont understand is why this usb wifi device that I have doesn’t work any more on the same desktop.
I have this thing lying around and use it sometimes in case the ethernet fails, been using it successfully in the past.
Now it shows the wifi applet as working, even the percentage is showing (80%), but there is no connection…

It tells me that r8169 is not loaded.

I’ve removed r8168 but then there is no network at all, so I reinstalled this one.

$ sudo nmcli dev status
DEVICE          TYPE      STATE      CONNECTION               
enp2s0          ethernet  connected  Wired connection 1       
ipv6leakintrf0  dummy     connected  pvpn-ipv6leak-protection 
lo              loopback  unmanaged  --   

That’s what i wasn’t sure if whether it was actually using r8168 or not. I guess it lists the other module even though it’s not loaded. So your issue must be something else.
This is mine on Ethernet and WiFi both connected.

[ricklinux@eos-kde ~]$ sudo nmcli dev status
[sudo] password for ricklinux: 
DEVICE   TYPE      STATE                   CONNECTION         
enp39s0  ethernet  connected               Wired connection 1 
wlan0    wifi      connected               xxxxxxx            
virbr0   bridge    connected (externally)  virbr0             
lo       loopback  unmanaged               --                 
[ricklinux@eos-kde ~]$ 

Or i disconnected WiFi

[ricklinux@eos-kde ~]$ sudo nmcli dev status
[sudo] password for ricklinux: 
DEVICE   TYPE      STATE                   CONNECTION         
enp39s0  ethernet  connected               Wired connection 1 
virbr0   bridge    connected (externally)  virbr0             
wlan0    wifi      disconnected            --                 
lo       loopback  unmanaged               --                 
[ricklinux@eos-kde ~]$ 

Edit: So is it working now then?

No, unfortunately not.
It says connected but there is no data coming in or going out.

Edit: I went back in time and the ethernet is working again, but…it is a thrill to update now. :joy:

Looking at the updates I see that there has been one for Realtek and it’s waiting again.

Are you using lts kernel?

Yes, but I have tried both.
I just updated the system and the internet is running normal again, so I don’t know what caused it.
The only thing I can think of is the installation of Proton VPN, this is gone now since I went back three days.

That is what i would think also that there is an issue with the vpn setup.

I just wanted to show you my output as it is the same as yours.

 Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI X570-A PRO driver: r8169 
           v: kernel modules: r8168 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200 

So on yours it shows driver r8168 and modules r8169.
On mine it shows driver r8169 and modules r8168. So i’m running on the r8169 and have the r8168 installed.

Now i have removed the r8168 package. Mine runs on either so you can see here.

Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI X570-A PRO driver: r8169 
           v: kernel port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200

Some will only work on the r8168 and others only work on the r8169 some work on both. Don’t know why that is.

Thanks for sharing Rick.
I still wonder what I have done wrong with that VPN setup.
I did the same on my laptop, without issues.

Well, hardly using it, so I’ll leave it as it is. (It’s a free vpn anyway)