Ethernet No Longer Works After Computer Suspended

Anyone else have this problem? After logging in from being suspended, my Ethernet tray icon turns into a loading circle, even though it says “Wired Connection 1” as if it’s established. I’ve tried creating a .service file from an askubuntu thread that I found but that didn’t work. Anything helps, thanks

Please post the output of:

inxi -Na

1 Like
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Micro-Star MSI driver: r8168 v: 8.049.02-NAPI modules: r8169 port: f000 
           bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200 

I think you’ll have to try the r8169 kernel module. Hopefully it works on this one and also resumes after suspend. The Realtek r8168 Ethernet card may (or may not!) work properly with the default r8169 kernel module. Thus EndeavourOS installs r8168 package by default. r8618 package contains the r8618 kernel module. Package r8168 also blacklists r8169. The best way would be to blacklist the r8168 instead of r8169 and then reboot and it should load the r8169. If it works and you can test from resuming then you’ll know.


Deleting r8168 package worked, thanks for your help


I didn’t want to tell you to uninstall the r8168 package in case it didn’t work and you had no way of connecting to reinstall it. Then you would have to chroot with the live iso and all that to get it installed again. Glad it worked.