Ethernet driver won't start on boot

Reinstalled EOS a couple months ago after a while on Windows and have been having an increasing number of issues since then.

Every time I reboot, I have to manually go and run sudo modprobe r8169 for the ethernet driver to start up because it refuses to start on its own. I’ve tried manually setting it to start on boot using /etc/modules-load.d/r8169.conf and no luck. The closest thing I can find online is that having the r8168 driver installed will blacklist the r8169 one, but I used the Welcome program to swap between the two drivers a few times, and it still does not work.

Here’s the output of inxi -FAZ --no-host, and the network output that could be relevant is below.

  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e
  IF: wlan0 state: down mac: 5a:f8:2c:ef:de:8b
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp42s0 state: up speed: 10 Mbps duplex: full mac: 04:7c:16:4d:64:dd

Been having another problem as well where my ethernet connection will occasionally and randomly drop for 5-20 seconds before coming back, though I’m not sure if it’s related or not. Any help would be appreciated for either of these issues.

Âllo Noelle,
Your motherboard:

Your current BIOS:
UEFI: American Megatrends LLC. v: 2.C0
date: 08/05/2022

The update that could help:
TitleVersionRelease DateFile Size


AMI BIOS7C95v2I2023-10-1217.49 MB

  • Description:
  • AGESA ComboAm4v2PI 1.2.0.B update. - AMD security issue patch.

Some of my machines were acting a bit like yours a couple of months ago. I made my updates to the BIOS and my 8169 or 8168 or OK now.

Might be interesting if yours will also improve :slight_smile:

Is there some red in here ? :

$ journalctl -g error -b 0

P.S. it’s possible a more knowledgeable member comes in to help also.

Edit (14h22 local): Just flashed my MSI B550 GAMING GEN 3 with the 1/11/2023 P.60 BIOS with the same CPU R7 as yours. The other version was from october (P.50). Took about 5-10 minutes, reassigned the 3200mhz memory frequency and she’s back online computing. Doesn’t take long. :slight_smile:

Additional reading:

1 Like

Lol, I can’t believe I somehow avoided doing a BIOS update ever since I built this thing. It’s updated now but unfortunately no luck in fixing the problem.

Edit: as for that command, there are plenty of red errors in there though I’m not which sure could be relevant. If there’s an easy way to upload this please let me know.

And about the other link posted, I’ve already made sure r8168 is uninstalled from the system, still no luck.

If r8168 is still installed, I would remove it altogether.
This should force r8169 to get loaded in the kernel at boot.

1 Like

Ok Noelle, I’m going to step patiently aside to learn more about this.
If you like to share the command you can use 3 backticks like this:

output here

Take care,

Wow, just opened blacklist.conf to see blacklist r8169 staring right back me. I cannot believe I somehow missed seeing that earlier. Guess I was only preoccupied with the /modules-load.d folder.

Doubt this will fix the issue of the connection dropping, though I’m not sure if I should make a new thread for that instead?