Ethernet does not work after opening from LockScreen

Specification: EndeavourOS with KDE Plasma

I mostly use Ethernet for my internet.
When I leave my laptop unattended, it automatically goes to the locked state.
Now when I log back in, I see the ethernet has been disconnected automatically.
It never connects automatically again.
I try plugging in the ethernet cable but still, it doesnot work.(when I am on Battery)
But, when I plug in my charger and then re-plug the ethernet cable, it just connects fine within a few seconds.

I am using the Latest updated Endeavour OS.But this issue existed ever since I installed EndeavourOS.

Please help me out :smile:

Welcome to the forum! :smile:

For starters to solve the problem, please show some details about your hardware.
You can do that with the help of the eos-log-tool app.

Alternatively, use command

inxi -Faz | eos-sendlog

Both of these commands return an internet address to a pastebin-like service where the information will be saved.
Please show the address here.

Thank you!

I ran the command and here is the link:

Have you tried the AUR package

yay -S rtw88-dkms-git

Here is info on the package.

Hi @ricklinux I tried the solution you suggested, Installed the driver it didnot help much.
But Now I am not even properly able to use LAN on battery now,
It now says limited connectivity after certain time on battery.
Even if I reconnect it says limited connectivity.
When I reconnect the LAN with my charger plugged in, it works absolutely fine.

By this time, I am guessing this might be some battery saving mode.
Is there any thing like in-built battery saving mode or so
that disables the LAN on Battery?

I don’t know if the powersave option would work turning it off or not. If it doesn’t work just remove it. You may end up having to go back to the original by removing the installed package rt8888-dkms-git


Add the following contents to the conf file:

wifi.powersave = 0