Ethernet connection drops at random times

Sorry i don’t agree with you as i stated it has nothing to do with the issue at hand. Updating the UEFI Firmware (Bios) is just something that should be done. I have done Bios & Firmware updates my entire life without issue. Today’s hardware makes it so easy to do it’s almost impossible to mess it up.

I encountered these instructions given by my computer’s manufacturer. Maybe I inferred incorrectly that this is the general best practice.

Hi! Again thanks guys, I really appreciate you trying to help me figure this issue out.

I don’t know what MTU is or jumbo frames, am pretty sure I haven’t modified any of them.

I’m not using a VPN on the PC or the router.

I can confirm that when the connection drops, LAN is accessible. I connected to my router’s web interface.

[jj@jj-systemproductname ~]$ ifconfig (did this when internet went away)
enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::7d9c:f6e6:2e59:5675 prefixlen 64 scopeid 0x20
ether 2c:fd:a1:6e:f7:01 txqueuelen 1000 (Ethernet)
RX packets 88421 bytes 79625658 (75.9 MiB)
RX errors 0 dropped 5 overruns 0 frame 0
TX packets 71030 bytes 9743445 (9.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16 memory 0xdf400000-df420000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 802 bytes 69340 (67.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 802 bytes 69340 (67.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.31 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::ac48:7859:a174:11f6 prefixlen 64 scopeid 0x20
ether 94:e6:f7:9d:93:2e txqueuelen 1000 (Ethernet)
RX packets 29736 bytes 23637399 (22.5 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 4287 bytes 532880 (520.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

I also logged into the router (while internet was offline) and pinged. These were the results

Pinging 192.168.0.1 with 64 bytes of data:[Complete]Reply from 192.168.0.1: bytes = 64, time = 0 ms

Reply from 192.168.0.1: bytes = 64, time = 0 ms

Reply from 192.168.0.1: bytes = 64, time = 0 ms

3/3 replies received.

min time=0 ms, max time=10 ms, avg time=0 ms

Motherboard firmware/BIOS needs to be updated because of security fixes, in additions to the reasons mentioned above.
Security is also one of the reasons why we need software updates.

It is true that updating with a wrong firmware/BIOS may brick the machine, so a user needs to be very careful getting the exactly correct version. And a power failure during the update can cause problems too.

Try switching to the LTS kernel, in case you are up against a kernel regression or similar.

sudo pacman -S linux-lts linux-lts-headers

Choose the new kernel in the menu of your boot manager (before you get to the login screen).

Hey. I appreciate the suggestion.

Installed the new kernel, switched to it as instructed. Sadly the internet keeps still randomly dropping.

Hmm, I’m not sure what it could be if it’s not the kernel. I guess the other thing enabled by default that a lot of other distros don’t have would be the firewall. It seems like a longshot, but try disabling the firewall to see if it makes a difference.

This might indicate that the issue is not with your PC at all, because if it were, you might expect both LAN and WAN access to stop working. However, your WiFi adaptor is still enabled, and the output of ifconfig indicates that it is transmitting and receiving data, which suggests you might have been accessing your router / LAN via the WiFi adaptor. I suspect this is actually the case.

You should disable your WiFi adaptor if you’re not actually wanting to use it. It will also help isolate the issue. You might perform the test again under those conditions.

Also, when the Internet is down you might run these tests:

  • On your PC, ping 1.1.1.1 (tests Internet access bypassing need for DNS resolution).
  • If that fails, on the router, ping 1.1.1.1 (assuming you can still access it without WiFi).

(1.1.1.1 is Cloudflare’s public DNS resolver, a reliable ping test)

Hey, I appreciate your suggestions!

How would I disable my wifi adaptor on Endeavouros?

There may be a simple way in your desktop environment, like turning on flight mode in KDE.

Using the command line though, this should disable wireless LAN:
rfkill block wlan

hey, thanks mate. i disabled the wireless lan, but didnt work. here are the commands i tested when the internet went away.

[jj@jj-systemproductname ~]$ ping 1.1.1.1
ping: connect: Network is unreachable
[jj@jj-systemproductname ~]$ ifconfig
enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::7d9c:f6e6:2e59:5675 prefixlen 64 scopeid 0x20
ether 2c:fd:a1:6e:f7:01 txqueuelen 1000 (Ethernet)
RX packets 9294081 bytes 13015411911 (12.1 GiB)
RX errors 0 dropped 59 overruns 0 frame 0
TX packets 3033920 bytes 259054331 (247.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16 memory 0xdf400000-df420000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 2102 bytes 224475 (219.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2102 bytes 224475 (219.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

[jj@jj-systemproductname ~]$

Have you tried disabling ipv6?

I think that’s worth trying, even if only to simplify things here. I noted that even earlier, your WLAN adaptor was assigned an IPv4 address, but your LAN was not.

1 Like

I ended up disabling ipv6 and deleted the wifi connections that were still remembered by the OS. This seems to have solved the issue.

I appreciate everyone who helped me figured this out! You are good people :slight_smile:

As a newbie I have some feedback to share when it comes to helping newbs like myself. If you give advice (such as “update firmware” - high risk) please make sure that the newb understands what the risks can be if you somehow manage to mess up the update. Looking back “update firmware” should be one of the last fixes that someone should try,

Again: thanks a bunch!

If you are referring to UEFI Bios updates i would disagree with this statement. UEFI Firmware(Bios) updates are extremely important for hardware. UEFI Firmware updates on today’s hardware are very easily done without issue.