Ethernet connection capped at 100Mbps, randomly disconnects

Hello, as the title states i have a connection that can do way past 400mbps, but it is capped at 90ish, Furthermore, it drops constantly after having tried to tweak some settings.
I tried to change the driver from r8168 to r8169 but i still get “link up” “link down” in dmesg,
r8169 said that was due to it dropping from 1000mbps to 100mbps, but then it died again.
This is in general just a nightmare i thought it would not be this hard to use ethernet…

Here are my specs: https://0x0.st/XMil.txt
I’m using a 20m CAT6 cable, should be more than enough

Nevermind, Learned that my router has some weird configuration with more than 2 cables connected in which one is uncapped and the others are capped to 100mbps, Now I get max speed, But should i stay on 8168 or should i use 8169

First, make sure you have the latest r8168 package in the cache
/var/cache/pacman/pkg
just in case.

Then uninstall r8168 and reboot.
If the ethernet connection does not work, reinstall r8168 and reboot.