Ethernet conflicts with wifi driver, eos hangs on boot

Hello!

I tried to install Atlantis but the installer hangs (see the picture attached). The hang happens when i try to install using the wireless adapter (the built-in one that comes with mai mobo - asus rog strix b550-e gaming - Intel Wifi 6 AX200). When i use the ethernet cable the installer does not hang and boots to the live image. The weird thing is that i installed Atlantis on my laptop (Tuxedo Pulse 15) which has “Intel Dual Band Wi-Fi 6 AX 200”. So on my pc the installer hangs when using the wireless adapter, but on my laptop it doesnt, and when i use the cable ethernet my pc goes to the live image.

Do you have any idea why this happens?

UPDATE
ok, so this is very weird…

Frustrated that this is happening I installed manjaro… well that did not go well. After I installed manjaro (with Ethernet cable) I unplugged it and switched to wireless. The same thing happend (hang on reboot).

At that moment it was more than clear that the problem has to do with the internet port/driver.

I remembered that my mobo comes with a intel lan port (that is buggy). I wen into bios and disabled the lan port and BAM everything works ok now. I’m using only the wireless port and disabled the lan one and the installer does not hang anymore at the point seen in the picture I attached to this post.

In conclusion I think there is a conflict between the intel lan port and the intel wireless port. My laptop has the same wireless adapter, but is has a Realtek lan adapter, and that is way the installation went completely normal on my Tuxedo Pulse 1 laptop.

For now I’m keeping the lan port disabled and going only wirelessly.

Welcome to the forum! Great that your are trying the new iso and it works on your laptop.

The problem is strange, by default the live iso boots into offline mode. Just plugging in the Ethernet should not remove your wifi driver or blacklist your wifi I think, so seems unrelated. When you are in the live iso and unplug the Ethernet, can you connect to your wifi?

Also, when you install eos is that problem persistent?

Please make sure to post your hardware and journal log infos first so others can help if it is driver/hardware related problem:

It’s the same WiFI and should be using same module so so i’m skeptical it has anything to do with WiFi. As @Zircon34 has posted a hardware log would be useful.

inxi -Fxxc0z --no-host | eos-sendlog

1 Like

https://clbin.com/C1srz

https://clbin.com/cgFsb

I did a fresh install using the ethernet cable

I installed all my usual programs and after i unpluged the ethernet cable the system hangs on restart

https://clbin.com/1ZDdO

this is the last one (again the system hangs (freezez) when restarting with wireless)

EDIT: this is a journal log from rebooting with ethernet
https://clbin.com/Ku27I

EDIT 2
the strange thing is that on vanila arch this does not happen

I see in each journal

dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: Direct firmware load for iwlwifi-cc-a0-66.ucode failed with error -2
dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: Direct firmware load for iwlwifi-cc-a0-65.ucode failed with error -2
dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: Direct firmware load for iwlwifi-cc-a0-64.ucode failed with error -2
dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: api flags index 2 larger than supported by driver
dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.37
dec 04 14:35:18 Sonia kernel: iwlwifi 0000:06:00.0: loaded firmware version 63.c04f3485.0 cc-a0-63.ucode op_mode iwlmvm

It looks like it fails to load on the newer firmware and is using the older version. I’m not sure if that is where it’s hanging. Does it actually finish booting and connect to WiFi? The explanation doesn’t really tell me. I guess you could rename the older firmware versions to see if it stops it from hanging and connects right away. Or is it not finishing even booting and or nor connecting at all when it does.

As for the OP’s update, it might be kernel is trying to load the same drivers for both or the LAN driver might be causing the WiFi drivers to crash which leads to a system panic and hang?

1 Like

Also in case you are dual boot with Windows. This is directly from Intels site.

About dual-boot with Windows and “fast-boot” enabled

If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don’t really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

@okunium
Have you actually installed it using the ethernet. Does it boot properly after it’s installed? Or you haven’t tried?

I have installed it using Ethernet and it boots just fine. The problem is that if I get of the Ethernet and go wireless then the system hangs when restarting or shutting down. This is the reason I have disabled the lan port in bios. It’s not very practical for me (the comp is very far from the router and the wire traverses the hole apartment) to use the Ethernet cable.

Basically it’s either lan either wireless for me, because I’m way to lazy to figure out the problem with de drivers. If the system works for me by disabling the lan port I’m fine with that workaround.

Ok so there might be a conflict between your wifi and Ethernet port driver.

This is what i wanted to verify. If it was actually doing this after installing as topic say’s hanging when installing. So i wanted to make sure I’m 100% understanding. :wink:

Network:   
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 06:00.0 chip-ID: 8086:2723
           IF: wlan0 state: up mac: <filter>
           
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3
           IF: enp7s0 state: down mac: <filter>

Also just wondering, what does kernel port N/A mean…

Edit: I mean not available, when it is not connected or does not recognize it to the right port…

Kernel port Not Assigned :man_shrugging: may be.

Not Available i assume? Or as @s4ndm4n say’s Not Assigned!

Edit: It shows down so it must be unplugged when command was done?

@okunium

Maybe check

sudo modprobe igc

Well the topic name was before I got to understand the problem. Initially using the wireless port (without disabling the lan port) did result with a hang in the installation process. Inserting the Ethernet cable (without disabling the wireless port) was enough to make possible the installation process.
For the wireless port to be effective in the installation process the lan port must be disabled.

So, in a nutshell:
a) just wireless (without disabling lan port) - installation hangs
b) just lan (without disabling wireless port) - installation works, boots fine but restart and shutdown hangs
c) just wireless (with lan port disabled) - installation works, boots fine and restart and shutdown work normally
d) just lan (with disabling wireless port) - did not try

1 Like

This ethernet uses igb or igc module.

According to the list having 2 network interfaces from the same vendor might be the cause of this issue. You could give the last option a try. If that works too that means there is a driver problem.