Error: yay: signature from "manuel <>" is unknown trust

This is the error I am getting after running sudo pacman -Syu

error: yay: signature from “manuel” is unknown trust

So far I have tried the following:

  • pacman-key --refresh-keys

  • Remove or reset all the keys installed in your system by removing the /etc/pacman.d/gnupg directory (as root) and by rerunning pacman-key --init followed by pacman-key --populate to re-add the default keys.

  • rm -rf /etc/pacman.d/gnupg

  • pacman-key --init

  • pacman-key --populate archlinux

  • gpg --refresh-keys

  • removing the file

  • Plus a few other things…

I have no idea what to do now. Please please help me :pensive:

1 Like
sudo pacman -Sy endeavouros-keyring
sudo pacman -Syu

Wow ok I feel super dumb. Thanks so much for the fast reply… I swear I tried looking for an answer. Just not hard enough I guess haha.

1 Like

Thanks, that helped me too. Quick question: how can users know when package endeavouros-keyring is updated?

1 Like

You can check for available updates by running the following command in terminal:


Thanks for this! :slight_smile:

1 Like

checkupdates, if not on your system, is within the pacman-contrib package.

Another goodie within that package is pactree, which will tell you the dependencies and reverse dependencies for a package.

So you run checkupdates and see a strange entry, say vim-runtime. Who needs that? You use pactree and see gvim does.

1 Like

I also tried pretty much everything OP did, with not much luck, but then the I also get the following error when running the first command from the post marked as the solution:

chris@chris-desktop ~ [1]> sudo pacman -Sy endeavouros-keyring
error: home_manuelschneid3r_Arch: signature from "home:manuelschneid3r OBS Project <>" is unknown trust
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 home_manuelschneid3r_Arch      1092,0   B  10,7 KiB/s 00:00 [--------------------------------] 100%
error: home_manuelschneid3r_Arch: signature from "home:manuelschneid3r OBS Project <>" is unknown trust
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

Any intuitions as to what I could try further?

It looks like you are having a additional repository in your pacman.conf which causes this error. It is not related to error mentioned in this post.
Please check your pacman.conf and comment or delete the repository home_manuelschneid3r_Arch. Then run the command sudo pacman -Sy endeavouros-keyring again.

1 Like

Thank you so much. I completely forgot about having added that (can’t even remember doing it, or for what purpose; how do you guys keep track?). I looked everywhere besides there. Lesson learned, hopefully :slight_smile:

1 Like

This thread saved me ongoing grief. Thanks!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.