Error writing to file: Read-only file system

One thing coming to mind - after deleting every partition, unplug the drive from usb-power. Then plug it back in to format…

1 Like

Just an idea for the cause but no solution: may it be - as this happens on large data trasnfers - that the controller of the external drive gets too hot and file system switches to r/o to prevent data loss or corruption.

I had something similar with a faulty drive in the past that randomely switched to r/o after a period of time. Mostly after heavier load on the disk…


Good to know…I will make that a habit next time…tks

Actually that could be one reason, because it always happened when I did large data transfers of large file or especially when I tried to copy like , eg 1000 small files, at one time that were in a folder…

Also, an observation, I have that external nvme drive in an external USB case. When I scan the drive for errors in ‘Disks’ app it says no disk errors found. I am wondering could it be the external USB enclosure that could be faulty? But then I tried another USB enclosure and the same happened… Which made it more strange and annoying. But yes it happened when I transferred large amounts of files same time.

I am wondering btw will adding more swap help reduce these failed to to errors? These errors don’t happen on my other EOS installed laptops at all often, and I think it only happened once or twice before in the last couple years. Just bizarre.

My experience was that my 256 GB SSD in an external usb case stopped two times at ~ 80% during a “create vm image from windows system”. The third time the disc could not be detected anymore when attachet to any PC/Laptop. I bought another (different brand) USB case and the ssd works again. So it was definetly the case or the controller chip in that case that caused errors and “killed himself”. May be it got too hot to achive high transfer rates for benchmarks but get unreliable during longer transfers.

In you case: are both usb cases of the same brand?


both different but the first case was definitely worse than the second case i tried…they seemed ok if I transferred one file at a time or just a few, but when I did big folder transfers with hundreds small tiles I got those read permissions errors about half way thru the transfer…

The disk worked correctly before?

I can remember fake SD Cards od USB sticks out there. Promising much more memory by firmware than actually present.

I’m somehow still on the hardware issue track. May be you could try another USB cable and port as another quick check.

…and something completely different: I had some weird issues transferring my backup through the on board ethernet of my laptop. LAN connection broke with a Rx -71 errors or somewhat. when backing up large video files or vm images. This was due to a faulty firmware file for the realtek 8153 chip. This is fixed now.
I remember that my external case for a nvme ssd shows up with a realtek signature in dmesg output as well.

Of course all no solutions but may be a hint in what direction to google

1 Like