Error while installing community editions of endeavouros

I’m getting this error Command pacman -Sy --needed --noconfirm - < /tmp/ce/bspwm.txt failed to finish in 600 seconds.
There was no output from the command.
Every time, I try to install a community edition of endevaouros, internet is fine and every community edition, bspwm,qtile, sway has this error.
For sway, it’s /tmp/ce/sway.txt
qtile, /tmp/ce/qtile.txt
I’m installing it on real hardware on an ssd.

yeah not to mention also ;


will see about that.

From this output it looks like it is downloading and then fails. You don’t get the download speeds/times from pacman in this situation but it looks like it is just taking a long time to download.

why does pacman doesn’t get the list of packages from the file or is it expected behaviour when you pass a list of packages from a file as the pacman log shows no list of packages.
pacman log from the mounted partition :
Look at the end of the log.

Also, I have tried other community editions and the same error comes in each of them. I don’t think it’s an internet issue as it fails in this specific point of installation.

the module that uses your Communitry Edition selection called contextualprocess is running the pacman command and is set to timeout after 600 seconds (10 minutes) and if calamares does not get any output for 600 seconds it bails out (timeout) for the process.

[2022-01-22T14:53:22+0500] [PACMAN] Running 'pacman -r /tmp/calamares-root-6pzwltx7
[2022-01-22T15:04:46+0500] [PACMAN] synchronizing package lists

we can HotFix this …


and i must add what we do add a lot of times already… online installs need a stable network connection and good working mirrors, as we see here also… it was a minute before finishing…
Also on a slower connection 10 minutes should work in most cases to install the packages.
If you are in a place where mirrors are little in number or internet connection is slow or unstable… the best workaround is to rank mirrors manually before starting the install process and add nearby and fallback like USA and Germany to the list.

The posted log is due, so I couldn’t review, so I will give a possibly better idea.

Instead of running a normal installation command, split it in two parts, one for download packages and one for installation, without any auto timeout/break.
If Calamares can give download progress info/message, instead of installation, which (progress) can be given in the real installation phase, the user will know which phase causes a problem, instead of assuming something other than network/repo/download process went wrong and forcefully stops the whole installation.

The issue is on pacman first, as it does not give useful output on fetching packages, but this is already a solved issue upstream at calamares and on testing.

At some point, installer must timeout if it does not register any output, if not it would freeze without any info given.

The issue is already addressed and solved and we are now able to get output in both stages of fetching and installing.