Error pipewire after a clean install

off the topic.
feel free to open a thread to discuss PipeWire vs. PulseAudio in general. :arrow_right:

Network manager and pipewire both pull in bluetooth dependencies. I had the same error. Installing wireplumber fixed the issue.

but is it an issue? if everything is working? it is only a false error. As long as you do not use Bluetooth.


No it is not a problem I am just OCD about my journal lol…

[elloquin@EndeavourOS-i3 ~]$ journalctl -p 3 -xb
-- Journal begins at Sat 2021-12-04 12:12:59 EST, ends at Mon 2021-12-06 16:31:48 EST. --
-- No entries --
[elloquin@EndeavourOS-i3 ~]$

looks like it will be the replacement for pipewire-media-session one day :wink:

1 Like

I found/tried two solutions:

  1. The solution also proposed by other friends (replace pipewire-media-session with wireplumber)

  2. During clean installation of endeavouros (xfce) disable all pipewire options (all of them).

Finally install pulseaudio (all options except Bluetooth)!

If I do this (second option) I risk to make the system unstable?

In both the first case and the second, I don’t get any errors at the end!

sudo journalctl -p 3 -xb is clean!

Is it preferable ( keeping in mind the stability of the system) to use option 1 or 2?


Edit: I personally have no issues with it on any of my systems with the audio.

my pc doesn’t have a Bluetooth card installed, that’s why I get the error regarding pipewire-media-session.

And that’s why I used to disable the Bluetooth plugin option when I installed the previous versions of endeavouros

I would be inclined to disable all pipewire options and then install pulseaudio but I’m afraid of making the system unstable (new version of endeavouros).

Why are you so concerned over a harmless message in your journal? This is not a problem, it’s just pipewire expecting to find something that doesn’t exist on your system. The functionality of the OS is not affected in any way.