Error on Update - Where is Log File?

For the past few days I have tried to run Welcome Update. Each time it tried to update Mega, it exited with a make file error.

I need to post the log file so the :enos: community can interpret it, but I can’t remember where the log file is located, so please help me out.

Also, since we were recently hit by Tropical Storm Fiona, our Internet has been a disaster and I think it may be possible some file got corrupted during the update. One minute we have 6mbps download and the next its 0.03mbps, up and down for weeks on end. I restored the oldest snapshot I have, but to no avail.

MEGA is my goto cloud, but each time it fails the update.

Btw, I tried the usual sudo pacman -Syu

I don’t think that is logged. You may have to try the build again and save the output.

In the worst case, mega provides a binary package which you could download for now to get you up and running again.

You may need to rebuild libpdfium-nojs to get mega to work again. It is probably still linked the prior version of icu.

Of course, if you have restored an old snapshot, that may not be applicable or possible.

1 Like

I got megasync-bin which is later than what I had.
MEGAsync is working again. Thank you as always.

Just for my interest, what is the syntax to rebuild libpdfium-nojs ?
What is “icu” ?

yay -S --rebuild libpdfium-nojs

It is a Unicode library that many packages depend on. Whenever it gets updated many packages need to be rebuilt. If you have any AUR packages that rely on it, it is your job to rebuild those.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.